Ford Power Stroke Nation banner

1 - 9 of 9 Posts

·
Registered
Joined
·
611 Posts
Discussion Starter #1
Ive noticed that it misses every now and then when Im sitting at a stop light, sometimes it surges too. Almost to the point where I think its going to shut off. Rpms are around 700 before it starts acting up and Ive seen them as low as 400-500. The truck starts fine cold but when hot it cranks alot longer than it does when its cold and when it fires it revs up to 1200 rpm and drops right back down to 700ish. Right now my fuel filter cap is leaking a little im waiting on my billet cap before I replace it. Would this cause my issue? Do i have a HPOP going bad?

Thanks
 

·
Registered
Joined
·
611 Posts
Discussion Starter #3
I checked codes and got nothing. Would RevX help?
 

·
Registered
Joined
·
30 Posts
It sounds like the ICP Sensor or wiring harness. If yours is an early '04 then it will be hard to look at because it is on the rear of the motor but the later '04s is easy to get to. Only thing is if it is a ICP Sensor it should throw a CEL.

Rev-X will help some of these problems, but you need to have the Injectors checked with a good scanner to make sure all of them are OK. Rev-X will improve Sticking injectors but when the injector is damaged it is not going to help.

Also how long have you had this truck, what oil are you using, how did it start when the weather was cold?
 

·
Registered
Joined
·
611 Posts
Discussion Starter #6
ive had it approx a month or so...and it started acting up 2weeks ago. Your basic obdII scanner. Im gonna run by ford and have them scan it on the way home.
 

·
Registered
Joined
·
611 Posts
Discussion Starter #7
Could it bee a small hpop leak?
 
1 - 9 of 9 Posts
Top