Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I just recently had all four injectors replaced on the driver side of my 2004 6.0 excursion. Previous to this the truck would accelerate/rev up a small amount at cruising speeds and when stopped. The reason for replacing the injectors was a bunch of white smoke and a cracked tip on one of the injectors. I thought the problem was fixed when the injectors were changed out. The shop also told me my alternator was only working sometimes. After my battery was dead on two separate occasions I changed the alternator and my battery’s have been fine. Today the truck started to rev again at highway speeds and cruising. Could the dead battery fry my ficm? Or could this be a different problem
 

·
Registered
Joined
·
3,690 Posts
The alt or batteries could have fried the ficm.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
68 Posts
Im going to tell you something i had a 04 6.0 with the same symptoms as you described look at the icp and ebp sensor were causing my issue disconnect the icp and see if it clears the issue run around with it disconnect as see if it goes away and clean the ebo tube
 

·
Registered
Joined
·
1,423 Posts
If you're talking about a brief rise in RPMs, like and up/down/up/down cycle, I would check the ICP and EBP like Woody said. If it's an actual acceleration for more than half a second, I'd be suspect of the FICM as well.
 

·
Registered
Joined
·
359 Posts
I had a similar issue.......it turned out to be a bad wiring harness/plug on the ICP sensor. You could watch the ICP voltage hunting up and down with my monitor....it was an easy problem to diagnose. But it was more of a hunting idle issue...not really a "the truck wants to take off down the road on it's own" issue .
 
1 - 5 of 5 Posts
Top