Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
First off Merry Christmas. I have a 03 6.0 EX that cranks but won't start. I have had a couple of time where it took a few long cranks to get it started but it eventually started and ran fine and then I didn't have any more problems for a Couple of weeks. Then it seemed to be running fine out on the highway until I came to a stop. It then started to run very rough like it was missing and cut off a couple of times but I was able to get it to start back up. Once I was going it smoothed out again but as soon as I came to a stop it would run rough and cut off. I made it to a Walmart parking lot and it died and has not started since. Once I had it towed home it seemed to be turning over slower than normal so I though the batteries might need charging from all the cranking. I charged the batteries, same result. I thought maybe the batteries are getting weak pulled them to have them tested and they showed good with about 700 CCA. Then I thought maybe I toasted the started cranking on it so I replaced the starter with a 6.4 starter. It seems to turn over faster than it did but still not like it should. When cranking it over it sounds like it is popping back through the intake. I thought it may be the ICP and unplugged it but that made no difference. I have attached a pic from torque with ficm readings. They look OK to me and I can hear the injectors buzzing when I first turn the key on. This is my main family vehicle vehicle and I really need to get it fixed so we can visit my parents for Christmas but it also dot have money to just throw at it. Any help would be greatly appreciated. If there is any more info that may be helpful I will be glad to provide it. I'm going to post a video on youtube of what it songs like craking. Thanks in advance.

Sent from my SM-G935V using Tapatalk
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #2 ·
First off Merry Christmas. I have a 03 6.0 EX that cranks but won't start. I have had a couple of time where it took a few long cranks to get it started but it eventually started and ran fine and then I didn't have any more problems for a Couple of weeks. Then it seemed to be running fine out on the highway until I came to a stop. It then started to run very rough like it was missing and cut off a couple of times but I was able to get it to start back up. Once I was going it smoothed out again but as soon as I came to a stop it would run rough and cut off. I made it to a Walmart parking lot and it died and has not started since. Once I had it towed home it seemed to be turning over slower than normal so I though the batteries might need charging from all the cranking. I charged the batteries, same result. I thought maybe the batteries are getting weak pulled them to have them tested and they showed good with about 700 CCA. Then I thought maybe I toasted the started cranking on it so I replaced the starter with a 6.4 starter. It seems to turn over faster than it did but still not like it should. When cranking it over it sounds like it is popping back through the intake. I thought it may be the ICP and unplugged it but that made no difference. I have attached a pic from torque with ficm readings. They look OK to me and I can hear the injectors buzzing when I first turn the key on. This is my main family vehicle vehicle and I really need to get it fixed so we can visit my parents for Christmas but it also dot have money to just throw at it. Any help would be greatly appreciated. If there is any more info that may be helpful I will be glad to provide it. I'm going to post a video on youtube of what it songs like craking. Thanks in advance.

youtu.be/eEjBbD2uqd0

Sent from my SM-G935V using Tapatalk


Sent from my SM-G935V using Tapatalk
 
1 - 5 of 5 Posts
Top