Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently fixed my fuel pump. an now Im able to drive the vehicle.. I idled approx 20mins. an drove it around my base.

It has a hard time accelerating. high rpms no accelerating..

I changed the cps sensor. acted a lil better but still no acceleration.

new fuel filer, new fuel pump, fuel in the housing bowl.

added some tranny fluid i was a lil low.

also since my truck has been sitting for a month. "i dont know if this as anything to do with it" but when i checked my oil cold.. I was way beyond the oil fill marker.. Idk if that has anything to do with it.. i dont even know where all that oil could have come from.. could that be a reason ?
 

·
Registered
Joined
·
245 Posts
If the oil looks to be over full and maybe a lite thin. Sniff it and see if there is diesel in it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
what about the fuel pressure regulator ? how can i test if thats bad ?

I say thise because i was able to get it running 2 days ago when i went out to the truck today. no fuel being sucked again from the fuel pump..

so maybe the regulator cant keep it pressurized?
 

·
Registered
Joined
·
23 Posts
in tank screens maybe clogged....also could cause pump to wear out.
combination of the two
 

·
Registered
Joined
·
62 Posts
you could try unplugging the throttle sensor on the pedal and clean it with electrical cleaner then plug it back in and see if that works if not and it is original one ford had problems and changed the sensors and you have to buy the pedal and all for 169.00 but if your lucky cleaning them will work or if you have acesss to a scaner that will help to locate the exact problem
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
you could try unplugging the throttle sensor on the pedal and clean it with electrical cleaner then plug it back in and see if that works if not and it is original one ford had problems and changed the sensors and you have to buy the pedal and all for 169.00 but if your lucky cleaning them will work or if you have acesss to a scaner that will help to locate the exact problem
thats guy for the tips I will look into this tomorrow. Im hoping i can atleast get it running to drive it not even a mile on my base to the hobby shop where I can do a diagnostics test on it.
that'll be on thurs day. I'll keep yall updated on the situation..
Its pretty sad Ive had the truck a month , an it only drove for about a week an half..
 
1 - 6 of 6 Posts
Top