Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Needs some help Today pulled out in traffic, truck just quit, Keep trying to start it, cranks but will not even try to fire, Had it towed home, Unloaded it from the roll back, and it fired right up, drove it about 6 miles, ran good, and it just quit again, had it towed home, same thing got it home fired right up, did run rough for about 30 seconds, Hooked the autel scan tool, and started check it, and quit again hour or so later fired right up, Not real familiar with diesels, so any help is appreciated. Truck is a 02 f250 cc srw, 284000 miles. All stock.
 

·
PSN intsigator
Joined
·
7,044 Posts
Check the CPS, or just replace itits only around 23 bucks from ford, DON'T use aftermarket. But it kinda sounds like tge IPR solenoid or wiring.

And welcome to the nation from WNC
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks, been hanging around for a while, just never needed to post till now, Thanks for the reply, update went out this morning and started checking things out, found a lot of oil in the valley, checked oil level, lost almost a quart in last 3 days, maybe drove 50 miles, hooked scan tool up, did all the test everything checked good, left the scan tool on live data, trucked started right up. ran good through all the test, let it idle for another 20 minutes or more, and it quit, just like someone turned the key off, scanner came up with ipr fault, truck cooled down and started right up till warmed up again, Would a bad IPR leak oil? or due I have a seal leaking when it gets warm?
 

·
PSN intsigator
Joined
·
7,044 Posts
Bad IPR will shut it down, I've never seen one leak there, but anything is possible. Id check turbo pedestal orings for the leak
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Thanks Heavydoc, Power washer the motor this afternoon and fired it up, found the fitting for the hose going to the dr. side valve cover is leaking, going to replace the pedestal orings now too, don't know if there leaking, but figured id do them just as insurance.
 

·
PSN intsigator
Joined
·
7,044 Posts
I would only use a motorcraft IPR, the off brand or aftermarkets have issues. I have gotten my last few off of Amazon. Just make sure it is a motorcraft and not just someone sayin it is
 

·
Registered
Joined
·
114 Posts
Did You pull the connector off the IPR and see if it is bleeding oil through? I guess if the valley is full of oil it must be pretty screwed up I never seen one leak that bad. Good Luck!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Just wanted to post a update, and to Thank everybody again for their help. Decided since I was working on it, I would go ahead and do some others things, So replaced the IPR, Oil lines and fittings, Installed oil line xover, rebuilt fuel filter housing and regulator, pedestal orings, and CPS. Running like a top, noticeably quieter and smoother,
 
1 - 8 of 8 Posts
Top