Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
00POWERSTROKE777
Joined
·
117 Posts
Discussion Starter #1
Hello I have a 00 7.3l with 165/80 injectors with jodys tunes and I have a weird rpm surge it does it at idle its a 500 rpm surge no engine codes runs great when im goin down the road it doesn't idle rough im kinda confused any help would be appreciated Thanks. .
 

·
Registered
Joined
·
616 Posts
Is this something that happened right after the injectors and tunes or did it run good with this setup for a while?
 

·
00POWERSTROKE777
Joined
·
117 Posts
Discussion Starter #3
It happened after I fired it up after the injector install ... but while I was doing the injector install I put a new idm from swamps the injectors and jody retuned for single shots. . But I noticed yesterday that when I unplugged the icp sensor it stopped surging ? Kinda confused me but now I know it's not high pressure oil problem .. Any thoughts? Has anyone had a issue like this from a bad icp sensor?
 

·
Bobs 7.3
Joined
·
2,852 Posts
Bad icp. Is there oil in the icp sensor and plug? If so then get a new icp sensor and plug or new icp sensor and clean the plug good with brake clean or electrical parts cleaner and use the original plug as I did 3 years ago.
 

·
00POWERSTROKE777
Joined
·
117 Posts
Discussion Starter #5
Yea there was oil on the plug ... I already got a icp sensor for it just haven't had the chance to throw it on. . Just kind of weird the problems im having not something u hear from a bad icp sensor at least none that ive heard of. .
 

·
Bobs 7.3
Joined
·
2,852 Posts
Yep just clean the stock plug out good and dry it out afterwards and put the new icp in and you should be good. The oil in them does strange things.
 

·
Registered
Joined
·
616 Posts
Have you driven it at all? It takes a few miles to get all the air purged out of the high pressure oil system.
 

·
00POWERSTROKE777
Joined
·
117 Posts
Discussion Starter #12
Finally got a chance to throw the new icp in. .. surge went away for the most part definitely helped still surges a bit maybe a 50-100 rpm surge .. hoping that's still the new injectors working the air out of the system.. Any body have an idea???
 
1 - 12 of 12 Posts
Top