Single turbo low/no boost nightmare - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Today, 06:07 AM Thread Starter
PSN Newb
 
TooManyTrucks's Avatar
 
Join Date: Apr 2019
Posts: 5
Single turbo low/no boost nightmare

Okay so I’ve searched and searched and tried so many different wordings to google I had to clear my cookies.. Maybe someone here can help with ideas..


The issue at hand is under normal acceleration I am only building 10psi of boost, if I drive aggressively I’ll see around 30ish floored I’m right around 40psi! Also once up to speed and leveled out I’m LUCKY to see 2-5psi (blows donkey balls, can’t got over 60mph because egts hang 950-1080). Literally my egts just moving through my yard will see 400-500 degrees ��. About a month ago it was fine! Normal boost under average acceleration cruising at 60-70mph would hold roughly 10-18psi depending. Since this started I’ve replaced..

-Up pipes and gaskets
-exhaust manifold gaskets
-intercooler
-cac pipes
-cac boots
-fresh new sxe366 from KC
-MAF sensor
-switched from an SCT GTX with Quicktricks tuning to MiniMaxx
-new intake horn
-fuel filters (wasn’t due to this but needed to be replaced)

Literally spent hours reading data from my Matco Maximus and NOTHING out of the ordinary.. The turbo will spool under WOT, but normal acceleration like I said I’m lucky to get 10psi, moderate acceleration 20ish. It’s a leak or sensor of some sort but I’m stumped at this point. I’ve check everything on the exhaust/hot side of the turbo and it’s good with no leaks.. So I’m assuming something with the intake area UNLESS possibly a sensor? But I can’t see which sensor would cause issues with a fixed geometry turbo 🏻 Also once in OD I literally have to hold it to the floor for a downshift and it to build boost to accelerate. Perhaps I am over thinking it so a shot in the dark here to see if anyone else with a single has had issues like this.. the truck isles smooth as a Prius, no odd smoke (except soot) still getting half decent fuel mileage...




My truck specs are as follows:
08’ F350 4x4 6.4
-single turbo twin scroll SXE366 with divided feed
-flopro up pipes not get branch
-6.0 BD exhaust manifolds
-ARP studs
-fass 200gph
-4” down pipe
-4” flo pro exhaust open
-Rudy’s CCV reroute oil fill
-Mishimoto CAC upgraded hot/cold cac pipes
-10% nozzles
-Mishimoto intercooler
-Mishimoto radiator
-Sno performance water methonal dual nozzles 3&6
-EGR delete
-Sinister intake horn
-Ported intake manifold
-Frankenstein trans done in house
-Mahle Coated cit pistons
-Carrillo rods
-RCD stage 2 cam
-chromoly push rods
And a ton of other s*** that doesn’t really matter...
TooManyTrucks is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Today, 03:38 PM
sooty
 
Join Date: Feb 2012
Posts: 378
Re: Single turbo low/no boost nightmare

What is rail pressure doing? A 366 is pretty big for a stock fuel truck. Try a smaller turbo.
sooty is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Low Power, Low Boost & No Timing jeffgut 1994-1997 Power Stroke Technical Info 3 05-22-2018 01:01 AM
2003 7.3 low boost very low egt no smoke help me! kfales 7.3L Power Stroke Technical Info 1 12-05-2013 09:29 PM
7.3 low power, low boost Jcavers 7.3L Power Stroke Technical Info 3 06-22-2013 11:40 PM
HELP van turbo swap nightmare Coopersauto 7.3L Power Stroke - Aftermarket & Performance 7 05-25-2010 03:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome