Intermittent Engine Idle Skip When AC Is ON - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-15-2019, 06:26 AM Thread Starter
TexasPowerStroke
 
derrickl11's Avatar
 
Join Date: Nov 2019
Location: Dripping Springs, Tx
Posts: 5
Intermittent Engine Idle Skip When AC Is ON

Hey fellow 6.4 owners,

I have just put a lot of work and money into my 2008 6.4 power stroke. (155k miles). NOW, the engine has a intermittent skip every 20-30 seconds when the AC is turned on. AND IT BOTHERS THE #### OUTTA ME.

My diesel tech has ran a contribution test and it doesn't show any injectors dropping out. It just shows a wave displaying across the screen across all when it "Skips". A compression test was done also and passed. My fuel pressure is showing 5,500psi at idle. NO codes are shown. The truck runs great once your on the road.

Why would the AC cause this somewhat power imbalance and engine idle skip with the AC on? Anyone else experience this?

Recent mods in the past 2 months:

1. New fan clutch
2. Whole new AC system.
3. New Up-pipes. And CAC Pipes.
4. New exhaust header manifolds. 4" turbo downpipe.
5. NEW FORD PCM.
6. Replaced the old H&S tune with new SCT GTX monitor.


Truck is already has full EGR delete. Straight pipe exhaust and cold air intake. with the new SCT tunes.

Respectfully,
Derrick Lee
derrickl11 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-15-2019, 11:45 AM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,738
If this happens every time the AC clutch disengages, put a diode in the power feed circuit to the AC clutch. It should have one already, but check to make sure it hasn’t failed.

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
post #3 of 8 (permalink) Old 11-16-2019, 02:02 AM Thread Starter
TexasPowerStroke
 
derrickl11's Avatar
 
Join Date: Nov 2019
Location: Dripping Springs, Tx
Posts: 5
Re: Intermittent Engine Idle Skip When AC Is ON

Matthew,

Could the diode be an potential issue even if the brand new ac system works perfectly fine? Could a failed diode cause the engine idle to skip? Like i said, the contribution test just displays a odd "wave" no complete drop outs.

Respectfully,
Derrick Lee
derrickl11 is offline  
 
post #4 of 8 (permalink) Old 11-16-2019, 02:21 AM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,738
When the ac coil de energizes, that stored energy has to go somewhere. Most vehicles have one installed from the factory in the fuse block or inline with the coil power supply. The diode prevents that energy from backfeeding back to the PCM or causing interference with the CKP (right next to ac compressor)or CPS sensors. A glitch in one of those sensor readings can cause a stumble. And voltage back feeding on circuits it shouldn’t can also cause this type of problem.

FWIW that odd wave you see is likely a disruption in the CKP sensor signal, or a result of voltage backfeeding the the PCM when the coil de enegergizes.

Is your mechanic using the IDS and VCM II for his testing?

This diode will likely have zero effect on the function of the compressor even if it’s bad.

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
post #5 of 8 (permalink) Old 11-16-2019, 12:38 PM Thread Starter
TexasPowerStroke
 
derrickl11's Avatar
 
Join Date: Nov 2019
Location: Dripping Springs, Tx
Posts: 5
Re: Intermittent Engine Idle Skip When AC Is ON

Matthew,

Thanks for the detailed information! I'm going to look into all this.

Im not sure what my mechanic is using but I can tell you its some high tech ####! lol

If these sensors and diode are cheap, I reckon ill just replace all of them and start there. The motor is solid and runs great its just the irritating weird engine idle skip with ac on.

Any other things you think I should look into? Thank again!!!!

Respectfully,
Derrick Lee
derrickl11 is offline  
post #6 of 8 (permalink) Old 11-16-2019, 01:14 PM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,738
I wouldn’t even bother with anything right now except for that diode.

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
post #7 of 8 (permalink) Old 11-16-2019, 06:32 PM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,738
The diode should be in the fuse box ( looks like a fuse but black with an arrow). It should flow current only one direction. It can be tested with a DVOM. In your case I believe it is open, or broken.

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
post #8 of 8 (permalink) Old 11-17-2019, 12:20 AM Thread Starter
TexasPowerStroke
 
derrickl11's Avatar
 
Join Date: Nov 2019
Location: Dripping Springs, Tx
Posts: 5
Re: Intermittent Engine Idle Skip When AC Is ON

I will start there!! Thanks again man! Ill let ya know,

Respectfully,
Derrick Lee
derrickl11 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome