Got me a new truck! - Page 6 - PowerStrokeNation : Ford Powerstroke Diesel Forum
 12Likes
Reply
 
LinkBack Thread Tools Display Modes
post #51 of 54 (permalink) Old 04-23-2019, 02:39 AM
PSN Local
 
Philhan69@aol.com's Avatar
 
Join Date: Jul 2017
Location: Gaffney S.C.
Posts: 218
Re: Got me a new truck!

I had a 97 mountaineer with the gt40p 5.0 engine. It's a really great engine . My neighbor still drives it daily with 320000 miles on it. Only problem I had was a cracked exhaust manifold on the passengers side.

Sent from my SM-G955U using Tapatalk
Sponsored Links
Advertisement
 
post #52 of 54 (permalink) Old 05-05-2019, 06:17 AM Thread Starter
Project Shamu
 
Lt.Dan's Avatar
 
Join Date: Mar 2015
Location: Visalia, Ca
Posts: 1,856
Re: Got me a new truck!

Well i got to wrench on it more today, got the dizzy reinstalled and set timing etc. It runs really smooth, so i mustve done something right.

The tow company I bought it from told me if the truck sits for a good period of time, that it will smoke a little on startup, and they think it had bad valve guides. Well, after sitting for 2 weeks, it smoked a little today. No worse than Shamu on a 15-20* morning though.

How hard is it to replace the valve guides on this thing?

I'm also looking at ways to clean up the engine bay, and make it look "simpler". IE, convert to an internally regulated alternator etc. Any other ideas?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1996 Cali F350 CCFB, 7.3 PSD, 2wd SAS, w/ 372,000 miles.
New Motor at 352,000, DieselSite Legendary Trans at 356,000 and many more


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1983 F150 SCSB Flareside, 302 w/ AOD Trans


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2002 F450 SCFB, 7.3 PSD 2wd w/ 144,000 miles
SOLD
Lt.Dan is offline  
post #53 of 54 (permalink) Old 05-05-2019, 11:05 PM Thread Starter
Project Shamu
 
Lt.Dan's Avatar
 
Join Date: Mar 2015
Location: Visalia, Ca
Posts: 1,856
Re: Got me a new truck!

Got to wrench on the truck a little more today. Did an oil change with some Valvoline MaxLife 5w-30 and a new motorcraft oil filter. Reinstalled the air cleaner and all the hoses associated with it, and took it for a drive. It runs surprisingly smooth, but it has some down sides.

It has a terribly dirty and disgusting interior, I want to just trash the seat, carpet, and headliner all together. The drivers door panel is missing, the window crank is missing and looks like the receiver end is broken, so the window is stuck in the down position, the door handle is missing so you have to open the door from the outside. The passenger side has a door panel, and everything is there, but the window crank just spins and isn't hooked up to anything lol. The headlight switch looks broken, there is no handle for it and the rod is pushed up under the dash, so you can't turn them on. The turn signals dont work at all, dunno why. The blower motor doesn't turn on in any position (I didn't expect the AC to work, but i expected it to atleast blow lol). The horn doesn't work, the Cruise control doesn't work. The list goes on with the interior lol.

The exterior isn't as bad, but has some issues. The passenger side mirror is broken and needs to be replaced, the truck originally only had 1 front tank, but there is a locked gas cap on it, and i think they couldn't get it off, so it looks like they put a hole in the back, installed a rear tank and plumbed some junk hose to fill it. But I tried to put some fresh fuel in it and it leaked from the filler neck real bad. I only got a gallon of fuel in before I said screw it. I don't even know if its pulling fuel from the front or rear tank, I have no key for the front locking gas cap, and there is no switch on the dash indicating it. So the fuel gauge could be reading from the front tank, but sucking gas from the rear etc. Who knows until I dig more into it.

But I went and put some air in the 10 y/o tires, and took it for a drive out in the country, the alignment is terrible as it feels really darty, but it surprisingly does well at 55mph. Lowish RPM's, doesnt seem to struggle or anything, but i was afraid to take it any faster until I know more about the truck, and had some better tires on it.

The trans seems to shift when its not suppose to, when you floor it, it just revs, but never shifts until you let off a bit. Must need to adjust the lever to the trans. It also had some clanking sound under harder acceleration, where it almost sounded like the fan was hitting the radiator, but its not. It eventually went away, the more I drove it.

I know thats a lot of info, but its a work in progress.

Some pics out in the country we have. Commiefornia aint all that bad, its got some sights, ill tell ya.



Attached Images
File Type: jpg 20190505_143820.jpg (290.8 KB, 29 views)
File Type: jpg 20190505_143826.jpg (264.6 KB, 29 views)
File Type: jpg 20190505_143832.jpg (304.6 KB, 29 views)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1996 Cali F350 CCFB, 7.3 PSD, 2wd SAS, w/ 372,000 miles.
New Motor at 352,000, DieselSite Legendary Trans at 356,000 and many more


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1983 F150 SCSB Flareside, 302 w/ AOD Trans


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2002 F450 SCFB, 7.3 PSD 2wd w/ 144,000 miles
SOLD
Lt.Dan is offline  
 
post #54 of 54 (permalink) Old 05-06-2019, 07:35 PM
Trust me, I got this...
 
Cummins Junkie's Avatar
 
Join Date: Apr 2016
Location: Not important
Posts: 1,162
Garage
Re: Got me a new truck!

Holy cow man sounds like you have your work cut out for ya.

Sent from my SM-J320V using Tapatalk

Shoulda bought a Cummins.

1997 F250 7.3L XLT, 4x4, 5spd, 315K, TS chip, BD Turbo-Thruster II, Donaldson 6637 filter, 4" straight piped dual exit SOLD

1995 F350 CCLB 5.8L XLT Tan leather interior. Soon to be swapped onto a 6.0 frame.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Pain is inevitable. Suffering is optional.
Cummins Junkie is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I got a new truck, Yall are gonna hate me. blackwaterstroker General Questions & Discussion 59 01-12-2010 09:10 PM
Got me some new tires mazdaparts General Questions & Discussion 6 02-28-2009 03:38 PM
Truck got the better of me today... jvencius 1999-2010 Super Duty General Aftermarket 10 02-12-2008 02:07 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome