Odd Behavior with my 1997 7.3 PS - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-18-2019, 02:30 AM Thread Starter
PSN Newb
 
Join Date: Apr 2019
Posts: 4
Odd Behavior with my 1997 7.3 PS

Hi everyone. I was hoping for some advice on my 1997 7.3 Powerstroke. I am the original owner. Mileage is 150K. Standard trans. regularly maintained. The only Mod is the EBP valve actuator linkage was disconnected years ago and the valve wired open. (I had cold weather drivability issues) Since then I learned that Ford in 97 had, in their infinite wisdom to put a 198 deg thermostat in this year instead of the 203 deg one IH had put in previous years. I swapped this out for the 203 years ago and this definitely made the truck run better.
The truck starts easily cold or warm. Idles and runs smoothly. revs up smoothly without a load, or with one. As of late when pulling hills or accelerating hard, I get a lot of black smoke from the exhaust and power is marginal.
My local dealer tells me I may have a bad injector, but everything I have read about this issue, always has rough idle/starting issues. I have just replaced the intake tubes downstream from the turbo. I checked the turbo while I had things apart. No play in the shaft and the vanes were not damaged. No change in the issue. I have also read the the screen in the fuel return line on the filter housing can become plugged. The symptoms for this do not seem to match my issue either. Any guesses what the issue could be?
I have experienced in the past,
The leaking oil galley plug seal.
The injector/ glow plug wiring meltdown
IDM replacement
Lift pump replacement

Thank you all in advance for any advice!
Stockstroker is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-20-2019, 02:34 PM Thread Starter
PSN Newb
 
Join Date: Apr 2019
Posts: 4
Re: Odd Behavior with my 1997 7.3 PS

I forgot to add the up pipes were replaced recently.
Stockstroker is offline  
post #3 of 4 (permalink) Old 04-20-2019, 02:54 PM
PSN intsigator
 
heavydoc's Avatar
 
Join Date: Apr 2016
Location: Keeping Yommy locked in the loony bin
Posts: 5,167
Re: Odd Behavior with my 1997 7.3 PS

Pre turbo exhaust leaks, plugged air filter, what's your hpop pressure, and IPR %

96 F350 rclb drw 2wd psd (built not bought)
01 Excursion Limited 4wd psd (the wifes ride)
02 F350 cclb drw 4wd psd (the land yacht)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
heavydoc is offline  
 
post #4 of 4 (permalink) Old 05-03-2019, 01:40 AM Thread Starter
PSN Newb
 
Join Date: Apr 2019
Posts: 4
Re: Odd Behavior with my 1997 7.3 PS

Thank you for the reply heavydoc!
I have been offline for a bit.
I had the up pipes replaced about a year ago. The intake tubes were replaced a month ago. I have not had the HPOP checked as the symptoms of this issue did not match, what I am experiencing. The air filter was replaced 5 moths ago and probably has less than 400 miles on it. The truck is not a daily driver as it is mostly delegated to snow plow duty, ( my own driveway, not commercially). Occasionally I drive it to work about 60 miles round trip. I pulled the fuel filter this afternoon and replaced it. It didn't look bad, I have seen it worse. While I had it apart I checked the FPR fuel pressure return screen, and it looks like it may be partially clogged. I will get to this on the weekend, and see if it helps. If not I will have the local Ford dealer check the HPOP. Is an IPR the same as an FPR? I am not familiar with that acronym. Thank you for your insight! Anybody else venture a guess?
Stockstroker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HFCM Behavior? Mattboost06 6.0L Power Stroke - Aftermarket & Performance 2 05-03-2016 03:13 AM
Good-Behavior Rewards Powerstroke Racer Politics and Religion 1 11-05-2013 01:37 PM
stage 1's and 6 pos chip, odd behavior cslimfu 1994-1997 Power Stroke Technical Info 6 10-11-2012 06:53 AM
Is this the usual behavior for a tune? 2002f-250 7.3L Power Stroke - Aftermarket & Performance 2 05-30-2012 06:58 AM
new to PS nation but not new to PS pistol60 New To The Nation 2 05-15-2010 04:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome