miss?? - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-21-2016, 08:46 PM Thread Starter
PSN Newb
 
Join Date: Apr 2016
Posts: 1
miss??

I have a 1994 ford f350 with the 7.3 turbo diesel. i have 1000k miles and never had a problem. the other day i was out driving around. i parked the truck for about 5 min and let it idle...when i got back in to drive it seems to have a miss now. the truck idles fine but when im driving it is very shaky and seems to almost be missing and have a slight lack of power. what could cause this all of a sudden? i changed the fuel filter about 4 months ago. the truck is not a daily driver. probably gets used about once a week on average. im not sure where to start?? i looked underneath cause at first i thought maybe a broken spring or shock cause im feeling a lot of vibration through the shifter and seemingly the rear of the truck?? could it be fuel related or injector? any help is much appreciated. thank you!
ryan0483 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome