Engine Idle - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-13-2015, 08:16 PM Thread Starter
PSN Newb
 
Join Date: Sep 2011
Posts: 11
Engine Idle

Hey Guys,
I'm new here and navigating through the site. Was wandering if anyone has experienced this issue. I have a 2013 King Ranch 6.7 and the engine idles in park up to 1000 rpms and a yellow engine light came on. The dealer ship said a code came on then turned off during maintenance and they could not figure out the problem. They gave it back and said if the engine light comes on I can drive it like that but it blows white smoke every now and then. The truck also idles four hours at work.

Roel Saldana

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
boost is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome