e4oD not downshifting after Rebuild - PowerStrokeNation : Ford Powerstroke Diesel Forum
 2Likes
  • 2 Post By Mark Kovalsky
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-22-2018, 08:46 PM Thread Starter
PSN Newb
 
Join Date: Jun 2018
Posts: 3
e4oD not downshifting after Rebuild

I need a little advice.

About two months ago I purchased a motor home based on the 1992 e-350 chassis. When I test drove the vehicle everything seemed great, however literally on the way home(after the sale) the transmission started to mildly slip. I checked the fluid and it was a bit low. I added a quart, but mild slipping still occurred on occasion. Last week I picked the motorhome up in preparation for a trip and the transmission was shifting at very high RPMs between gears 1 and 2. I checked the transmission fluid and it was high. I used a fluid transfer pump to remove some of the transmission fluid that I had put in a couple of months earlier. After removing more than I put in a few months earlier the fluid was still way to high. I decided to take it in to the local transmission shop. When i got to the shop the the vehicle was loosing ATF at a very rapid rate. I did not check to see where the leak was coming from but I assume it was between the bell housing and engine due to the rate.

The manager from the transmission shop called a few days later to tell me that i needed to have a rebuild. He said the transmission was toast and was surprised that I was able to drive the motorhome there. I gave him the Okay to complete the rebuild.

Fast forward a week... The manager calls to tell me the rebuild has been completed, however there is an issue. The transmission shifts through all the gears flawlessly at initial startup. When you come to a stop or slow down the transmission fails to downshift. The only way to get it to back into 1st is to manually move the shifter through the gears and eventually it will downshift. The manager indicated that they had put countless hours into this and had replaced all the sensors on the transmission. They have determined this is an electrical problem and "they don't do electrical"

1. Any suggestions as to why this symptom would appear after a rebuild? I never experienced this downshifting issue prior to taking it to the shop.
2. The manager of the shop has essentially indicated that they have done all they can. I assume he wants payment however I don't really think that is appropriate being that there is still a transmission problem... Any advice here?
3. I was also told that they nor the local dealership have the right diagnostic equipment due to the age of the vehicle. I did a bit of research and this year has the EEC IV diagnostics and I assume he is referring to something more comprehensive than a code reader... Any ideas what diagnostic equipment he might be referring too?

As a side note: The transmission shop I am working with seem like good guys and are really trying hard to get me back on the road.
kxm0331 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-23-2018, 05:00 AM
PSN Veteran
 
​ DieselDC's Avatar
 
Join Date: Nov 2016
Posts: 1,008
Re: e4oD not downshifting after Rebuild

“Go pound sand”. Pay them nothing and take your truck back (if you can). Generally a law suit is needed if they don’t give it back willingly.

For a shop that rebuilds Transmissions and not know how to fix electrical chit relating to Transmissions is stupid.

Down shifting is done via pcm - hell all shifting is done by the pcm (when in D).

Think of it this way... if there are no codes pointing to the solenoid pack and tc, it ain’t electrical. It’s mechanical and they screwed something up. Somethings up with the vb and or accumulator or both (broke valves/springs, wrong torque, leaks btwn the cells etc).

I could be wrong but that’s how 4r100s work.


—————signature—————
~Don’t overthink something simple~
...:uptight people suck:...
​ DieselDC is offline  
post #3 of 9 (permalink) Old 06-23-2018, 06:50 AM
PSN Veteran
 
79jasper's Avatar
 
Join Date: Mar 2012
Location: Skiatook Oklahoma
Posts: 3,670
Re: e4oD not downshifting after Rebuild

Yup, it's internal.
Mark K would know more.
Definitely looks like grounds for a lawsuit.

Sent from my SM-G892A using Tapatalk

1979 chevy c30 dually, sm465, 373's? Converted to 6.2 diesel, pump turned up and advanced a hair.(wrecked)
1994 ford F350 dually 4X4: 7.3 powerstroke, 5 speed. 6637, straight pipe into dual stacks. Cooper discoverer at/3's.
2010 Jetta TDI 40 or so mpg :flippa:
79jasper is offline  
 
post #4 of 9 (permalink) Old 06-23-2018, 12:03 PM
Native Texan
 
masakimm's Avatar
 
Join Date: May 2016
Location: North Central Mo
Posts: 8,908
Garage
Re: e4oD not downshifting after Rebuild

more then likely they put it together wrong there were differences in the e4od based on model years if they go things out of place because they used info from a newer model e4od. I went thru my e4od 3 times to get the internal all right. And I am an ASE Master tech. the e4od has to be done right and they will bite u if u don't pay attention. They need to pull the valve body and figure out what they screwed up.

"Y'all have a wonderful"
"My name is Bob the guy floating in the lake with no arms and no legs"
Bob W Martin 1948-2014 USAF


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Upgrades:
|Bellowed UpPipes|160CC Injectors|Adrenaline HPOP|Rebuilt Turbo 360 Bearing|Custom E-Fuel|Manual to Auto Conversion
|Delete Pedestal|3" Down Pipe 4" Exhaust|Dual Tensioner and Belt|Stainless Steel HPX Crossover|Custom Banks InterCooler
|42 Gal Rear Tank 35 Gal Front Tank |DP Infinity Tuner
masakimm is offline  
post #5 of 9 (permalink) Old 06-23-2018, 01:18 PM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,019
Re: e4oD not downshifting after Rebuild

Quote:
Originally Posted by kxm0331 View Post
As a side note: The transmission shop I am working with seem like good guys and are really trying hard to get me back on the road.
...but they really don't know what they are doing.
79jasper and masakimm like this.

Mark
Former Ford Automatic Transmission Engineer

“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
post #6 of 9 (permalink) Old 06-24-2018, 09:58 AM Thread Starter
PSN Newb
 
Join Date: Jun 2018
Posts: 3
Thanks for the advice.
Can one of you guys comment on the diagnostic equipment the manager of this shop is referring too? The reason why I am focused here is that manager seems convinced the tranmission is fine and the root cause is electrical. I dont think he is going to be willing pull the tranmission and open it up without conclusive proof that there is not an issue outside the transmission.

From my research I have determined that the 1992 e-350 has a EEC IV. I know you can pull codes and according to the internet, later versions of vehicles can stream telemetry data from this interface. Maybe he is thinking the TPS or speedometer are not working properly???

If I knew what diagnostic equipment he is referring too, perhaps I could find a shop close by and get this shop to refocus their efforts on the transmission.
kxm0331 is offline  
post #7 of 9 (permalink) Old 06-24-2018, 11:58 AM
Native Texan
 
masakimm's Avatar
 
Join Date: May 2016
Location: North Central Mo
Posts: 8,908
Garage
Re: e4oD not downshifting after Rebuild

any good professional scanner should be able to talk to it. We have a Snap on modis and a modis ultra and both will talk to them just fine.

"Y'all have a wonderful"
"My name is Bob the guy floating in the lake with no arms and no legs"
Bob W Martin 1948-2014 USAF


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Upgrades:
|Bellowed UpPipes|160CC Injectors|Adrenaline HPOP|Rebuilt Turbo 360 Bearing|Custom E-Fuel|Manual to Auto Conversion
|Delete Pedestal|3" Down Pipe 4" Exhaust|Dual Tensioner and Belt|Stainless Steel HPX Crossover|Custom Banks InterCooler
|42 Gal Rear Tank 35 Gal Front Tank |DP Infinity Tuner
masakimm is offline  
post #8 of 9 (permalink) Old 07-01-2018, 11:35 PM Thread Starter
PSN Newb
 
Join Date: Jun 2018
Posts: 3
Re: e4oD not downshifting after Rebuild

A quick update and a couple of questions.

1. The computer is throwing a couple of error codes:
#29 Vehicle Speed Sensor problem – VSS
#67 Intermittent Park Neutral Position (PNP) sensor fault – PNP | Transmission Manual Lever Position (MLP) sensor circuit – Transmissions | Park/Neutral circuit fault – PNP

2. The shop has a machine called "trans-x". I am not familiar with this equipment but from what i understand it sits between the transmission and PCM. This machine can also take over PCM. According to the mechanic the transmission behaves properly when this machine is connected. They also said they can see that the PCM is not sending the signal to downshift.

3. The mechanic indicated that he was not getting a reading from the VSS test port. This port is located in the front driver side compartment(by the headlight) by the EEC IV test port. As a test the mechanic ran a jumper from the VSS(in the rear diff) to the vss test port. The transmission shifts up and down the gears properly approximately 5 times. After 5 times the failures to downshift reappear...

4. The VSS sensor and MLPS sensor has been replaced. Also the speedometer seems to be working fine.

All of the symptoms seem to point towards an electrical or PCM issue. Whats driving me nuts is that this downshifting issue was not present prior to the rebuild.

???Is there any data that is sent from the transmission to the PCN that influences when it should downshift??? If so, what components are responsible?

I was going to head down to the shop and see if there is a way to test the VSS signal at the PCN. I found some wiring diagrams that indicate that pin 3 and 6 are the VSS. How would you suggest tapping into these connections? The test procedure I have suggests a breakout box(T83L-50-EEC-IV) while driving however I don't have this equipment.


Thanks!
kxm0331 is offline  
post #9 of 9 (permalink) Old 07-02-2018, 02:13 AM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,019
Re: e4oD not downshifting after Rebuild

Quote:
Originally Posted by kxm0331 View Post
???Is there any data that is sent from the transmission to the PCN that influences when it should downshift??? If so, what components are responsible?
The PCM looks at vehicle speed and accelerator pedal position to determine when to downshift. It doesn't look at anything from the transmission itself for that decision.

It's possible that during the R&R of the transmission some of the wiring was damaged and that is causing this issue.

Mark
Former Ford Automatic Transmission Engineer

“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome