Early 99 weird knocking sound. - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-03-2017, 04:50 PM Thread Starter
PSN Newb
 
Early99 Ron's Avatar
 
Join Date: May 2016
Posts: 19
Early 99 weird knocking sound.

Ok so this is a 1 owner truck recently with a all new fuel system OEM new fuel pump, new sender with screens, IPR, HPOP, new Garret turbo with WW2, FPR 4 in exhaust, HYDRA chip PHP and recently flashed at the dealer from XLE4 to new strategy but I believe the chip over rides that. Truck has 225,000 miles on it. The problem I'm experiencing is the truck seems slow to build up boost and in 1st and 2nd gear it has high rpm and won't shift until I let off the gas using the chip. Fluid looks excellent I've changed it about 3 times in the last year. Torque converter also does not seem to have a lot of bite really also. Another thing is when it warms up and you use it hard it has a weird knock under the truck, if you crank the wheel all the way left or right in drive it lugs and knocks harder almost stalling the motor same with reverse. In park the knock is almost knock there but as soon as you go to drive or reverse it knocks hard and almost wants to stall, anyone know what could cause this?
Early99 Ron is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-05-2017, 12:51 PM
PSN Veteran
 
410customs's Avatar
 
Join Date: Aug 2016
Location: Idaho panhandle
Posts: 3,323
Re: Early 99 weird knocking sound.

that is odd
Sounds like a possible torque converter issue

1997 CCFB 7.3, ZF5, 4x4, 4.10, baby swamps, TS6, E99 spyder, RiffRaff pipes, 6.0 FMIC, RSK, 315 toyo at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2001 Excursion 7.3, auto, 4x4, 3.73, 6" Suspension lift, 37" Dick Cepeks
2000 E350 7.3, auto 2wd, 3.73, planning a TTB 4x4 conversion
21.9 liter family
410customs is offline  
post #3 of 8 (permalink) Old 08-12-2017, 05:39 PM Thread Starter
PSN Newb
 
Early99 Ron's Avatar
 
Join Date: May 2016
Posts: 19
Oh it's odd truck does not use any oil at all fires right up but just had no torque at all I can get it up to 24 psi at 3000 rpm with a 80hp PHP tune but it's like I'm going no where and in stock it constantly downshifts and I can rpm but no speed and feel no torque
Early99 Ron is offline  
 
post #4 of 8 (permalink) Old 08-22-2017, 02:30 PM
STROKER
 
Join Date: Aug 2017
Location: CO
Posts: 13
Re: Early 99 weird knocking sound.

that sounds like a torque converter problem to me, almost as if you lost some fins on the turbine, stator, or rotor or maybe all three.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

GETSUM
2002heavyhauler is offline  
post #5 of 8 (permalink) Old 08-29-2017, 02:03 PM Thread Starter
PSN Newb
 
Early99 Ron's Avatar
 
Join Date: May 2016
Posts: 19
Fuel pressure is at 60psi and drops to 55psi WOT, now with a 80hp tune after I run it hard it has a sparatic knock real inconsistent, I've replaced all boots lined collector up replaced exhaust manifolds up pipes and doughnuts. She also has a knock on the passenger side all the time I've pulled that valve cover off and unplugged injectors for a hour trying to make a difference in sound, only thing I thought was not normal was the tiny air bubbles coming out of the middle injector and I have big bubbles coming out of the first injector on that side. It has Delo 400LE oil in it and new HPOP new IPR and rebuilt injectors. Anyone have a clue? She downshifts but no speed gain and no pull unless I put it to the floor.
Early99 Ron is offline  
post #6 of 8 (permalink) Old 09-05-2017, 12:52 AM
PSN Veteran
 
longjonsilver's Avatar
 
Join Date: Jun 2017
Location: Upstate South Carolina
Posts: 1,018
Re: Early 99 weird knocking sound.

Sounds like you've got compression leaks either through the copper sealing ring on the injector or the injector cup . Air in the fuel system will cause a real nasty knocking sound . I'd pull the known leaking injectors and replace the o rings and copper sealing gaskets and fire it off


Sent from my iPhone using Tapatalk
longjonsilver is offline  
post #7 of 8 (permalink) Old 09-11-2017, 12:35 AM Thread Starter
PSN Newb
 
Early99 Ron's Avatar
 
Join Date: May 2016
Posts: 19
Longjohnsilver, thank you for the idea I will remove all injectors and try re sealing, when I tightened the injectors I used a dial style inch pound wrench, I probably should have tightened by hand to double check.
Early99 Ron is offline  
post #8 of 8 (permalink) Old 09-13-2017, 09:38 PM Thread Starter
PSN Newb
 
Early99 Ron's Avatar
 
Join Date: May 2016
Posts: 19
I have another question for all of you when I put my truck in to drive it will not move on it's own anymore usually at one and this is forward and reverse plus it always knocks The torque converter is original and so is the transmission
Early99 Ron is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome