E4OD! Need help badly!! - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 12-17-2015, 12:50 AM Thread Starter
PSN Newb
 
Join Date: Dec 2015
Posts: 6
E4OD! Need help badly!!

Hey guys, I've searched and searched and can not come up with a fix! First off let me tell you the back ground of my truck... I'll give you the short version! I bought my 97 and drove it home. (300km trip) went to work on it a couple days later and all it would do it smoke white. I ended up buying a parts truck from a good friend and swapped the motor and trans. The trans only had 500kms on it. I got it all back together and started driving it. First I noticed that the trans shifted way too fast into OD. (Around 30mph). Then I noticed there was no passing gear... So I did some searching and started replacing parts. I replaced the TPS, the shift solenoid and the wiring harness... Ive gotten the truck to where there's kickdown now, but it only happens around 3/4 throttle, anything more and it goes into kickdown then shifts immediately... And it's still shifting into OD at 30 mph and lugs the truck... What do I do? I've looked at all the electrical plugs and everything seems fine...
NorthernOBS is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 12-17-2015, 12:53 AM Thread Starter
PSN Newb
 
Join Date: Dec 2015
Posts: 6
Re: E4OD! Need help badly!!

I forgot to mention that my TPS with the pedal to the floor is reading 6.5volts.. I can't get it to read anywhere 4.5 to save my life.. And it is reading 6.5volts at 3/4 throttle... I've drilled the holes bigger and still nothing...
NorthernOBS is offline  
post #3 of 10 (permalink) Old 12-17-2015, 01:31 AM
PSN Veteran
 
old Smokey's Avatar
 
Join Date: Aug 2012
Location: Minnesota
Posts: 1,177
Re: E4OD! Need help badly!!

You could try a different computer. You could try the one from your donor truck.

96 with 320,000, Idm mod,
Tc mod, van turbo, 200/30 rosewood,
T 500 hpop, Dy 3" down pipe,
glowshift gauges, D60kp swap, custom track arms,
steering wheel swap, 6637 mod, Hydra chip, WW2,
calf fuel spring and BB mod
6.0 fan, cooler,
Pmf 2.25 rsk sd springs

78 f-150 turbo big block
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
old Smokey is offline  
 
post #4 of 10 (permalink) Old 12-17-2015, 01:39 AM
PSN Local
 
Dusten's Avatar
 
Join Date: Mar 2008
Location: Marysville, Wa
Posts: 62
Re: E4OD! Need help badly!!

Quote:
Originally Posted by NorthernOBS View Post
I forgot to mention that my TPS with the pedal to the floor is reading 6.5volts.. I can't get it to read anywhere 4.5 to save my life.. And it is reading 6.5volts at 3/4 throttle... I've drilled the holes bigger and still nothing...
Where are you measuring voltage?

2001 Ford Lightning - Built Motor - 2.3 KB - Built Trans - Custom Interior - Garage Queen
1968 Ford Mustang - Gold Nugget
1994 Ford Cobra - stock
1993 Ford Lightning - Ongoing restoration
Dusten is offline  
post #5 of 10 (permalink) Old 12-17-2015, 10:54 AM Thread Starter
PSN Newb
 
Join Date: Dec 2015
Posts: 6
Re: E4OD! Need help badly!!

I tried the doner computer and nothing changed. I'm measuring the voltage at the tps connector at the throttle pedal...
NorthernOBS is offline  
post #6 of 10 (permalink) Old 12-17-2015, 12:31 PM
PSN Local
 
Dusten's Avatar
 
Join Date: Mar 2008
Location: Marysville, Wa
Posts: 62
Re: E4OD! Need help badly!!

Quote:
Originally Posted by NorthernOBS View Post
I tried the doner computer and nothing changed. I'm measuring the voltage at the tps connector at the throttle pedal...
Ecm won't change vintage read out. It's odd your seeing that voltage, as that sensor should never show more than 5v
Does the voltage sweep as you press the pedal

2001 Ford Lightning - Built Motor - 2.3 KB - Built Trans - Custom Interior - Garage Queen
1968 Ford Mustang - Gold Nugget
1994 Ford Cobra - stock
1993 Ford Lightning - Ongoing restoration
Dusten is offline  
post #7 of 10 (permalink) Old 12-17-2015, 02:42 PM Thread Starter
PSN Newb
 
Join Date: Dec 2015
Posts: 6
Yea, it Shows .90 volts at idle position and sweeps from there. It's at 4.5 volts around 3/4 throttle. Which make sense cause at 3/4 throttle it will kick down, anything more then 3/4 throttle and it kicks down then locks up immediately...
NorthernOBS is offline  
post #8 of 10 (permalink) Old 12-17-2015, 07:05 PM
PSN Local
 
Dusten's Avatar
 
Join Date: Mar 2008
Location: Marysville, Wa
Posts: 62
Re: E4OD! Need help badly!!

That makes sense. The ecm cant understand more than 5v and going into failsafe mode

2001 Ford Lightning - Built Motor - 2.3 KB - Built Trans - Custom Interior - Garage Queen
1968 Ford Mustang - Gold Nugget
1994 Ford Cobra - stock
1993 Ford Lightning - Ongoing restoration
Dusten is offline  
post #9 of 10 (permalink) Old 12-17-2015, 07:37 PM Thread Starter
PSN Newb
 
Join Date: Dec 2015
Posts: 6
Re: E4OD! Need help badly!!

Thoughts on what to do?
NorthernOBS is offline  
post #10 of 10 (permalink) Old 12-17-2015, 10:02 PM
PSN Local
 
Dusten's Avatar
 
Join Date: Mar 2008
Location: Marysville, Wa
Posts: 62
Re: E4OD! Need help badly!!

Quote:
Originally Posted by NorthernOBS View Post
Thoughts on what to do?
If you've swapped sensors, you need to get schematics and check input voltage. Look for a short that might be causing the issue

2001 Ford Lightning - Built Motor - 2.3 KB - Built Trans - Custom Interior - Garage Queen
1968 Ford Mustang - Gold Nugget
1994 Ford Cobra - stock
1993 Ford Lightning - Ongoing restoration
Dusten is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome