E4OD OD light flashing - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old 07-11-2015, 07:34 PM Thread Starter
PSN Local
 
Join Date: Apr 2015
Posts: 129
E4OD OD light flashing

I need some assistance. I have a 97 psd 4x4, recently I have noticed that the torque converter fails to lock up and I will pull off the road and shut the truck off and restart and the problem goes away. This happens intermittently not everyday. I thought it may be the truck being cold or something like that. My father in law said he never had any issues with the truck and that the trans was rebuilt some time ago by previous owner. Truck had no codes and is shifting fine.

Yesterday I installed a TS 6 pos chip. When I started the truck the OD light was flashing. When I put it in drive the light stops flashing and the OD button works. Truck seems to drive and shifts like before. Could the chip just intensify a previous problem or could the chip be bad? All the positions on the chip work.
I tried to scan for codes but none were stored in the computer.

Could it be a bad tq converter or bad solenoids?


97 F250HD XLT. 4x4 7.3 CCSB, 140,000 miles, 33" tires, 355 limited slip rear axle, 4" turbo back and 6637 Intake, glow shift gauges, PHP 6 position chip.

I don't know what's next.
PSD ADAM is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 07-11-2015, 07:59 PM
Administrator
 
Zmann's Avatar
 
Join Date: Nov 2010
Posts: 32,929
Re: E4OD OD light flashing

there is a code if the light is flashing but you need a good reader

,
,
,
,
DTR's Donation page

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

RIP DTR Ron
you are missed and will live on through your great video library contribution to the DIY community

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Zmann is offline  
post #3 of 22 (permalink) Old 07-12-2015, 12:59 AM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,028
Re: E4OD OD light flashing

Quote:
Originally Posted by PSD ADAM View Post
Could it be a bad tq converter or bad solenoids?
Yes it could. Or bad wiring. Or bad sensors, some of them are not even on the transmission. Or an internal trans problem.

There are codes stored. You need a better tool than you have to read them. Without the codes all I can do is list everything and you go buy it all and install them until the problem goes away.

Mark
Former Ford Automatic Transmission Engineer

“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
 
post #4 of 22 (permalink) Old 07-12-2015, 03:23 AM Thread Starter
PSN Local
 
Join Date: Apr 2015
Posts: 129
Re: E4OD OD light flashing

The code is 0708

I checked the connector on the trans and it's connected.
I also noticed when selecting gears, say from reverse to drive the light will flash and the shift into drive is a little more harsh.


97 F250HD XLT. 4x4 7.3 CCSB, 140,000 miles, 33" tires, 355 limited slip rear axle, 4" turbo back and 6637 Intake, glow shift gauges, PHP 6 position chip.

I don't know what's next.
PSD ADAM is offline  
post #5 of 22 (permalink) Old 07-12-2015, 01:57 PM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,028
Re: E4OD OD light flashing

That indicates an electrical problem with the Transmission Range Sensor (TRS.) The TRS is located on the driver's side of the transmission. It is the part with the wiring harness attached to it. The problem could be the TRS itself OR the wiring between the TRS and the PCM.

Mark
Former Ford Automatic Transmission Engineer

“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
post #6 of 22 (permalink) Old 07-12-2015, 07:44 PM Thread Starter
PSN Local
 
Join Date: Apr 2015
Posts: 129
Re: E4OD OD light flashing

Changed the sensor and no change.
Could the TS 6 pos chip effect this at all?
Also in park the truck seems to be idling a little high, around 850 rpm


97 F250HD XLT. 4x4 7.3 CCSB, 140,000 miles, 33" tires, 355 limited slip rear axle, 4" turbo back and 6637 Intake, glow shift gauges, PHP 6 position chip.

I don't know what's next.
PSD ADAM is offline  
post #7 of 22 (permalink) Old 07-12-2015, 09:52 PM Thread Starter
PSN Local
 
Join Date: Apr 2015
Posts: 129
Re: E4OD OD light flashing

Update

I pulled my TS chip and problem went away. I'll be calling KT performance tomorrow


97 F250HD XLT. 4x4 7.3 CCSB, 140,000 miles, 33" tires, 355 limited slip rear axle, 4" turbo back and 6637 Intake, glow shift gauges, PHP 6 position chip.

I don't know what's next.
PSD ADAM is offline  
post #8 of 22 (permalink) Old 07-14-2015, 02:07 AM Thread Starter
PSN Local
 
Join Date: Apr 2015
Posts: 129
Re: E4OD OD light flashing

Have to send my chip back. KT performance customer service is awesome, Kenny is the man over there.


97 F250HD XLT. 4x4 7.3 CCSB, 140,000 miles, 33" tires, 355 limited slip rear axle, 4" turbo back and 6637 Intake, glow shift gauges, PHP 6 position chip.

I don't know what's next.
PSD ADAM is offline  
post #9 of 22 (permalink) Old 07-16-2015, 01:17 AM
PSN Veteran
 
Join Date: Aug 2011
Location: Denton, TX
Posts: 965
Re: E4OD OD light flashing

I recall my TS instructions said the %99 of the problems with chip installs are a failure to properly clean the contacts.

1996 F250 CCSB, 4x4, auto PSD, stainless window vents.

Signature file limitations keep me from sharing more information. Follow this link to find my threads: D60 RSK install, Air vent cleaning, etc.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
leojr is offline  
post #10 of 22 (permalink) Old 07-16-2015, 04:03 AM Thread Starter
PSN Local
 
Join Date: Apr 2015
Posts: 129
Re: E4OD OD light flashing

I'm sure most are however my chip was programmed for an E350 Canada built van.
So I don't think I'm in that 99%.


97 F250HD XLT. 4x4 7.3 CCSB, 140,000 miles, 33" tires, 355 limited slip rear axle, 4" turbo back and 6637 Intake, glow shift gauges, PHP 6 position chip.

I don't know what's next.
PSD ADAM is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome