speedo - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-28-2009, 11:06 PM Thread Starter
PSN Veteran
 
reis1995's Avatar
 
Join Date: Feb 2009
Posts: 700
speedo

My speedo don't work at all until about 50mph and until it gets there and stays there for about 40 sec the od light flash's. But once i get to fifty every thing is fine and it reads fine but if i drop below fifty the speedo drops to 0 immediatly and the od light starts flashing again. Any ideas?
reis1995 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-29-2009, 12:00 AM
PSN Veteran
 
Layson's Avatar
 
Join Date: Jul 2007
Location: Corvallis, OR
Posts: 3,432
Re: speedo

What type of truck do you have? Sounds like an ABS sensor?? Anybody around to read codes for you?
Layson is offline  
post #3 of 7 (permalink) Old 08-29-2009, 03:12 AM Thread Starter
PSN Veteran
 
reis1995's Avatar
 
Join Date: Feb 2009
Posts: 700
Re: speedo

early 99 f-250
reis1995 is offline  
 
post #4 of 7 (permalink) Old 08-29-2009, 04:03 AM
PSN Veteran
 
Layson's Avatar
 
Join Date: Jul 2007
Location: Corvallis, OR
Posts: 3,432
Re: speedo

Kind of sounds like a bad ABS sensor. See if you can find someone to read codes. You might beable to post up and find someone in your area with AE software. Where are you at?
Layson is offline  
post #5 of 7 (permalink) Old 08-29-2009, 04:59 AM Thread Starter
PSN Veteran
 
reis1995's Avatar
 
Join Date: Feb 2009
Posts: 700
Re: speedo

Western KY But that sounds right cause my friends truck just started doing the same thing. Only his starts working at 30 and his abs light came on. Thanks for the help.
reis1995 is offline  
post #6 of 7 (permalink) Old 08-29-2009, 05:11 AM
PSN Veteran
 
Layson's Avatar
 
Join Date: Jul 2007
Location: Corvallis, OR
Posts: 3,432
Re: speedo

There are three abs sensors. One in each front wheel bearing and one in the rear diff. If one of those are off then it will screw with the computer...
Layson is offline  
post #7 of 7 (permalink) Old 08-29-2009, 05:21 AM Thread Starter
PSN Veteran
 
reis1995's Avatar
 
Join Date: Feb 2009
Posts: 700
Re: speedo

i may be wrong but i don't think my truck has abs in the front so i'm almost positive it the one in the rear differ.
reis1995 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome