4r100 slipping rebuilt multiple times - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-05-2014, 06:16 PM Thread Starter
PSN Local
 
powerstrokin44's Avatar
 
Join Date: Oct 2010
Location: Havre de Grace, MD
Posts: 70
4r100 slipping rebuilt multiple times

I have a 4r100 behind my 7.3 with 250/100 and a 66 h2e. The trans is always perfect when it gets done but after about 4-5 months it starts slipping bad even when the converter is locked first 2 times the clutches were burnt and the triple disk converters went out the third time the forward drum was cracked and converter was out so I switched from a trans specialties triple to a precision triple disk. Now about six months later it's slipping again except instead of just slipping when I apply power it also chatters and does not feel like its in gear when I put it in drive but reverse feels fine. Is there a common problem that could cause all these reoccurring issues? Help please I'm tired of my truck being down twice a year! lol

2000 F-250 Stroker, Cale's tunes, modded H2E, Full Force 250/100, Built tranny from John Richmond, Precision converter, Manley rods, Mahle pistons, clevite bearings, girdle, sbi valves, a1000, Comp springs, Smith bros pushrods, billet plenums, DI RR.
powerstrokin44 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-07-2014, 03:04 AM
mech 1
 
Join Date: Apr 2014
Location: vidor
Posts: 288
Re: 4r100 slipping rebuilt multiple times

pump pressure and broken or worn valve spring in the body will cause this whic clutches were burnt the worst
7.3mud is offline  
post #3 of 4 (permalink) Old 10-07-2014, 04:51 PM
Freak'n know it all
 
gottagofast's Avatar
 
Join Date: Nov 2010
Location: near Louisville in Indiana
Posts: 3,004
Re: 4r100 slipping rebuilt multiple times

Sounds to me like you have the wrong guy building ur trans.... Never hear anything like this with BTS or JW

.
99.5 350 crewcab dually 4x4
stage 1 singles, PHP tunes, banks bighead,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
autometer gauges,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, South Bend HD clutch, Gen 2 wicked wheel, AIS intake system.
gottagofast is offline  
 
post #4 of 4 (permalink) Old 10-07-2014, 05:17 PM
4Anna
 
Chuck@bdp's Avatar
 
Join Date: Sep 2014
Posts: 9
Re: 4r100 slipping rebuilt multiple times

Check line pressures, I would lean towards a bad pump

Chuck
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome