Tranny problems - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-20-2009, 12:51 AM Thread Starter
PSN Veteran
 
Hassler Diesel's Avatar
 
Join Date: Jul 2009
Posts: 717
Tranny problems

So i had a fully built trans except for shafts. i snapped my input shaft off and took the trans in and got billet input intermediate output and foreword drum put in. before i snapped my input i could push 41 psi. put my trans back in i can only push 35psi. now it started not to shift, just red line, and the boost level just keeps getting lower i can only push 20psi now. and the truck just red lines all the time. anybody have a clue. i was told computer wasnt that. Told oil pump have plenty of pressure. told change speed sensors and pulled them out and there was metal on the one???????
Hassler Diesel is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-20-2009, 12:20 PM
PSN Veteran
 
JimTJr's Avatar
 
Join Date: Jul 2007
Posts: 1,888
Re: Tranny problems

Quote:
Originally Posted by Hassler Diesel View Post
So i had a fully built trans except for shafts. i snapped my input shaft off and took the trans in and got billet input intermediate output and foreword drum put in. before i snapped my input i could push 41 psi. put my trans back in i can only push 35psi. now it started not to shift, just red line, and the boost level just keeps getting lower i can only push 20psi now. and the truck just red lines all the time. anybody have a clue. i was told computer wasnt that. Told oil pump have plenty of pressure. told change speed sensors and pulled them out and there was metal on the one???????
Sounds like your trans is still bad... small particles of metal on the sensor is probably nothing to worry about, larger chunks, yes.
The transmission is slipping causing the truck to redline? I mean, that is the only thing between your motor and the tires/ground. The motor won't "REDLINE" and the truck not go anywhere if the trans is working right......

So,, I would go back to the builder and have them look at it,,,,,,

(This is where I have to say,,, if it was a BTS and you had problems, I am sure it would be ZERO cost to get it fixed,,,,, ) Doubtful you won't have to pay again with your builder...
Brian put new parts in mine after three years, when he swapped the trans from my 99 to the 03 PSD. NOTHING was wrong with that trans, it was just new upgrades he came out with after I bought mine, only charged me fluid and a pittance for R&R.... (His "warranty" is two years unlimited miles, unlimited HP/Torque, officially)

Good luck!

*48* Jim T. 2011 F-350 Lariat, CC, LB, SRW. White Platinum Metallic Tricoat. Black leather seats, I probably wont have*PMS,, with this one, at least no major attacks of it!
JimTJr is offline  
post #3 of 6 (permalink) Old 07-20-2009, 01:19 PM
Lovin the Tuna
 
RedSmokey's Avatar
 
Join Date: Oct 2008
Location: Sacramento CA
Posts: 8,353
Re: Tranny problems

i was thinking simliar. A slipping tranny wouldnt put as much load on the motor to get full boost. But i dont know about only getting half the boost you used to.

2001 F250
2000 F250
RedSmokey is offline  
 
post #4 of 6 (permalink) Old 07-20-2009, 09:13 PM Thread Starter
PSN Veteran
 
Hassler Diesel's Avatar
 
Join Date: Jul 2009
Posts: 717
Re: Tranny problems

i took it over today and he said its my computer, that the truck is in fail safe mode. that the motor just isnt putting out the power that it was. which that don't make sence because its red lining all the time, its not transferring the power to the ground
Hassler Diesel is offline  
post #5 of 6 (permalink) Old 07-20-2009, 10:07 PM
Lovin the Tuna
 
RedSmokey's Avatar
 
Join Date: Oct 2008
Location: Sacramento CA
Posts: 8,353
Re: Tranny problems

could be "limp" mode.

2001 F250
2000 F250
RedSmokey is offline  
post #6 of 6 (permalink) Old 07-20-2009, 11:19 PM Thread Starter
PSN Veteran
 
Hassler Diesel's Avatar
 
Join Date: Jul 2009
Posts: 717
Re: Tranny problems

best way to get it out of limp mode, pull batterys and leave key on over night???
Hassler Diesel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome