Tranny Issues - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-03-2014, 02:34 PM Thread Starter
PSN Newb
 
Join Date: Dec 2012
Posts: 41
Tranny Issues

So I recently bought a newer zf5. This guy had the tranny rebuilt and then got in an accident so he was parting it out. So I bought it and put it in my truck. He said that this tranny wasn't made for thinner fluids. But I put what was recommended for that tranny. It shifts really nice and is just a nice transmission. The only problem is is that when the truck is warm and I'm in a higher gear and I start to go slow then it will internally churn inside and makes a weird noise but then when I get going over 1500 rpms then it won't do this. Could this be because of thinner fluid needed to be thicker or what?? Thanks in advance!!
Powerstroker88 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome