e40d tranny dropping into neutral randomly - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 47 (permalink) Old 04-28-2014, 07:58 PM Thread Starter
PSN Newb
 
Join Date: Apr 2014
Posts: 22
e40d tranny dropping into neutral randomly

Hi I'm new to this forum. How this is the right place to post for tranny issues. So i have a 97 f250 2wd powerstroke with the e40d 4spd trans. I have paper work starting the tranny was rebuilt 50k ago. And while I'm driving usually in 4th it will just pop into neutral. I have to pull over for a bit before driving again. It shifts great drives smooth. But every one in a while fall into neutral. I read alot and everyone said the mlps. I replaced the mlps and plug. It ran good for few days. And it's doing it again. Please help. I need my truck back on the road asap. Thank you in advance.
galmo22 is offline  
Sponsored Links
Advertisement
 
post #2 of 47 (permalink) Old 04-28-2014, 08:00 PM Thread Starter
PSN Newb
 
Join Date: Apr 2014
Posts: 22
Re: e40d tranny dropping into neutral randomly

Sorry for the typos. Im on my phone
galmo22 is offline  
post #3 of 47 (permalink) Old 04-29-2014, 05:10 AM Thread Starter
PSN Newb
 
Join Date: Apr 2014
Posts: 22
Re: e40d tranny dropping into neutral randomly

So the codes Im getting are. P0708 transmission range sensor a circuit high
P0707 transmission range sensor a circuit low.
Since I just replaced the trs. Why would i be getting these codes?
galmo22 is offline  
 
post #4 of 47 (permalink) Old 04-29-2014, 11:39 AM
PSN Local
 
Join Date: Apr 2012
Location: Bunker Hill, MI
Posts: 496
Re: e40d tranny dropping into neutral randomly

You might want to put this in the transmission section.
msscatter is offline  
post #5 of 47 (permalink) Old 05-08-2014, 01:56 AM Thread Starter
PSN Newb
 
Join Date: Apr 2014
Posts: 22
Re: e40d tranny dropping into neutral randomly

bump
galmo22 is offline  
post #6 of 47 (permalink) Old 05-08-2014, 10:48 AM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,029
Re: e40d tranny dropping into neutral randomly

You either have installed a defective MLPS or you have a damaged wire or dirty connection in the wiring between the computer and the MLPS. I'm betting on a wiring issue.

Mark
Former Ford Automatic Transmission Engineer

“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
post #7 of 47 (permalink) Old 07-02-2014, 03:42 AM Thread Starter
PSN Newb
 
Join Date: Apr 2014
Posts: 22
Re: e40d tranny dropping into neutral randomly

thankyou mark kovalsky. anyway to track down the wiring problem? i didnt see any damage to the wiring from mlps to computer.. any way to test the wires?
galmo22 is offline  
post #8 of 47 (permalink) Old 07-02-2014, 03:43 AM Thread Starter
PSN Newb
 
Join Date: Apr 2014
Posts: 22
Re: e40d tranny dropping into neutral randomly

also sometimes it wont shift out of 1st in drive. i can manually shift into 2ed tho. also random occurrences. could it be solenoid pack or speed sensor or somthing like that?
galmo22 is offline  
post #9 of 47 (permalink) Old 07-03-2014, 02:29 PM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,029
Re: e40d tranny dropping into neutral randomly

It could be, but it is because of the problems with the MLPS. Get that fixed and everything should be fine.

You need a VOM and a wiring diagram to check the wiring. Check between the PCM and the MLPS. Sometimes the best way to do this is to take it to a really good independent shop that specializes in electrical problems. With the right equipment and a lot of experience it isn't hard to find problems like this.

Mark
Former Ford Automatic Transmission Engineer

“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
post #10 of 47 (permalink) Old 07-03-2014, 02:45 PM Thread Starter
PSN Newb
 
Join Date: Apr 2014
Posts: 22
Re: e40d tranny dropping into neutral randomly

Ok thanks again. So am i checking for ohms? Or just continuity?
galmo22 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome