E4OD pump seal keeps going out - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-27-2012, 08:21 AM Thread Starter
PSN Newb
 
Montanastroker's Avatar
 
Join Date: Aug 2012
Location: Troy,Montana
Posts: 3
E4OD pump seal keeps going out

I am a 95 f-250 with the e4od and it keeps blowing or blows the tranny fluid right by the front seal.I am kinda new to this tranny stuff but i rebuilt it in Jan. and have had it in and out 5 times cause it keeps leaking fluid out the front pump seal. the first i rebuilt it...new clutch discs,steals,seals,pump,converter and bushing kit...the second time new front pump seal and solenoid pack...third time new front seal and went threw the valve body...forth time i finally checked the pump which was a remann and the front bushing was coming out so i put a new bushing in it and new seal which lasted about 2 weeks without leaking which was the longest it had lasted since i put it back together.....so i sent the pump back and they sent me another one which i inspected the bushing first thing and put it in today and lasted about 2 min before it started leaking again....any ideas what in the heck is going on here??? i have spent hour upon hours more like days reading everything i can and talking to tranny guys about this and no one can give me any kinda answer!!!
Montanastroker is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-27-2012, 10:44 AM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,025
Re: E4OD pump seal keeps going out

Did the pump damage the surface of the torque converter where the seal rides? If that surface is anything less than perfect the seal is going to fail.

Mark
Former Ford Automatic Transmission Engineer

“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
post #3 of 6 (permalink) Old 08-27-2012, 05:43 PM
Diesel Sled Head
 
zx800x's Avatar
 
Join Date: Aug 2007
Location: Minnesota
Posts: 1,101
Re: E4OD pump seal keeps going out

Cooler restricted??

2001 f250 H2E,BTS,Stealth,reg return,mod IDM, spearco,DI Ceramic Headers.. bcode stage 3's Cale's Tunes
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zx800x is offline  
 
post #4 of 6 (permalink) Old 08-27-2012, 07:15 PM Thread Starter
PSN Newb
 
Montanastroker's Avatar
 
Join Date: Aug 2012
Location: Troy,Montana
Posts: 3
Re: E4OD pump seal keeps going out

The surface of the converter are smooth as the day i got it. Not sure about a restricted cooler though. how would i check that? last time i had the tranny out i took air and blew out the lines
Montanastroker is offline  
post #5 of 6 (permalink) Old 08-29-2012, 09:11 PM Thread Starter
PSN Newb
 
Montanastroker's Avatar
 
Join Date: Aug 2012
Location: Troy,Montana
Posts: 3
Re: E4OD pump seal keeps going out

Any other ideas?
Montanastroker is offline  
post #6 of 6 (permalink) Old 08-31-2012, 02:04 PM
PSN Veteran
 
cpdad93's Avatar
 
Join Date: May 2012
Location: Emmett ID
Posts: 1,395
Re: E4OD pump seal keeps going out

mine had this stupid magnet up on the cooling line and it was plugged
cpdad93 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome