ZF6 Problems - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-08-2012, 02:31 AM Thread Starter
PSN Newb
 
Join Date: Jul 2012
Location: Cleveland, Ohio
Posts: 24
ZF6 Problems

Sorry if this has been asked guys I have searched around.

I have I believe a Late 99 F550 4x4 zf6 Chassis truck. I have 2 problems

1. While the truck is running in neutral there is a knocking noise coming ffrom the trans that goes away when the clutch pedal is depressed, once you release the pedal the noise comes right back.

2. This happens only while driving making it hard for me to diag, but while driving my truck if I hit a rough patch of road (i.e. bumps, pot holes ect.) then go to push the clutch in, the pedal gets extremely hard and I am unable to depress it, after a few quick stabs it functions normally again.

I don't know if these problems are related or not but I am hoping someone can point me in the right direction.
THanks
Dave
Djchunter is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome