ZF6 Soft Clutch - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-28-2012, 04:55 PM Thread Starter
99 f250
 
Join Date: Dec 2011
Location: Minnesota
Posts: 29
ZF6 Soft Clutch

Yesterday after pulling my boat up the ramp in 2nd (whoops), clutch has gradually been feeling softer more often. I'm sure you've heard this before, feels like there's nothing behind it it will engage/disengage every once in-awhile. But not on command.

I used the Search feature and originally thought I had it diagnosed as the slave cylinder but after reading through multiple threads and seeing the multitude of problems with the recommended ford kit, and not being entirely confident in myself to not drop the push rod into the bell-housing, I thought would question those with experience.

Could it be the clutch fork?

Especially since none of the ford dealerships part/service is open due to the holiday, but they will sell you a car.

That being said I have the utmost respect for the men and women who have and will fight and die for my freedom.
Willman940 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome