something wrong??? - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-05-2012, 05:15 PM Thread Starter
cjsobas
 
cjsobas's Avatar
 
Join Date: Jan 2011
Location: marysville ohio
Posts: 53
something wrong???

so i just got a new transmission. old one was slipping bad. i went ahead and got all the parts. racer x triple disk compition converter. racer x alto red eagle clutchs and steeles and a bts valve body. i took all my parts to ATS in marysville ohio to be put in as i did not trust myself after tearing a diff tranny down.
well the problem im running into is on shifts i hear the rpms jump for a split sec then catchs a gear. not all the time just sometimes. but its starting to get worse. my friends hearwhat im talking about but my stupid old man doesnt neather does bill at ats. .

HELP!!!!!!

2000 F350 7.3l custom 5in exhaust, glowshift pillar gauges, 4in sky jacker lift, edge evo only on tow built tranny/ bts valve body/alto clutches and steeles/racer x triple disk torque converter, 20in moto metel 955, 35/12.50r20 nitto m/t, ww, 2ton helper springs
.
cjsobas is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-05-2012, 07:51 PM Thread Starter
cjsobas
 
cjsobas's Avatar
 
Join Date: Jan 2011
Location: marysville ohio
Posts: 53
Re: something wrong???

anyone got any ideas. do you think something is wrong or is it just me being paranoid

2000 F350 7.3l custom 5in exhaust, glowshift pillar gauges, 4in sky jacker lift, edge evo only on tow built tranny/ bts valve body/alto clutches and steeles/racer x triple disk torque converter, 20in moto metel 955, 35/12.50r20 nitto m/t, ww, 2ton helper springs
.
cjsobas is offline  
post #3 of 7 (permalink) Old 05-05-2012, 08:11 PM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,029
Re: something wrong???

The RPM should NEVER go up at the start of a shift. That just adds energy to the clutch, which wears it out much faster.

Find someone with a good scan tool that can look at data. Record engine speed during a shift so you can have real data to show what's happening.

Mark
Former Ford Automatic Transmission Engineer

“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
 
post #4 of 7 (permalink) Old 05-06-2012, 02:15 PM Thread Starter
cjsobas
 
cjsobas's Avatar
 
Join Date: Jan 2011
Location: marysville ohio
Posts: 53
Re: something wrong???

I used snap on motis and did throw codes but I did See it go up rt b4 a shift

2000 F350 7.3l custom 5in exhaust, glowshift pillar gauges, 4in sky jacker lift, edge evo only on tow built tranny/ bts valve body/alto clutches and steeles/racer x triple disk torque converter, 20in moto metel 955, 35/12.50r20 nitto m/t, ww, 2ton helper springs
.
cjsobas is offline  
post #5 of 7 (permalink) Old 05-06-2012, 03:04 PM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,029
Re: something wrong???

If it has codes those are REALLY big clues as to what's wrong.

Mark
Former Ford Automatic Transmission Engineer

“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
post #6 of 7 (permalink) Old 08-05-2012, 02:31 AM Thread Starter
cjsobas
 
cjsobas's Avatar
 
Join Date: Jan 2011
Location: marysville ohio
Posts: 53
Re: something wrong???

my bad it didnt throw any codes. sorry been so busy havent had a chance to reply. but it only does this on the stock tune. when i add the 60 hp or any higher it shifts fine. my other ? is weather the Eagle X6TC and bts valve body go good together. and how did other people like there bts valve body. me i dont notice any diffrence really between the stock one and the bts besides when the torque converter locks up

2000 F350 7.3l custom 5in exhaust, glowshift pillar gauges, 4in sky jacker lift, edge evo only on tow built tranny/ bts valve body/alto clutches and steeles/racer x triple disk torque converter, 20in moto metel 955, 35/12.50r20 nitto m/t, ww, 2ton helper springs
.
cjsobas is offline  
post #7 of 7 (permalink) Old 08-06-2012, 04:03 AM
PSN Veteran
 
bracketracer's Avatar
 
Join Date: Oct 2011
Posts: 630
Re: something wrong???

You might need to get ahold of both your chip tuner and BTS and find out how they set up your stuff. If BTS set up your valve body assuming TS altered the shift feel in ALL settings but TS left the stock setting truly "stock", would that not account for your flare? Just my $0.02

Newest project: 1995 F350 CC/DRW 2WD E4OD. 3" DP, 4" Diamond Eye system. But I'm still fixin' the broken stuff......
bracketracer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome