Is it the oil? - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 07-27-2009, 12:51 AM Thread Starter
PSN Local
 
trucknut56's Avatar
 
Join Date: Feb 2009
Location: Brussels ON CANADA
Posts: 122
Is it the oil?

I just switched from rotella 10W30 to SWEPCO 15W40. I changed the oil saturday, it ran good after the change but sunday it idled rough visibly smoked more and just didnt feel the same. The truck is stock except for 4 inch straight pipe exhaust to 2 six inch mitre cut stacks. There are no codes. The truck has 109,000 KM on it. Before the oil change it ran fine.
trucknut56 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 07-27-2009, 04:57 PM
PSN Veteran
 
Join Date: Jan 2009
Location: Wellington NV.
Posts: 4,810
Re: Is it the oil?

Is the Swepco a rated Diesel oil? Why change?

We only carry the BEST parts and never compromise just to get a sale.

Dealer for: Full Force, Tymar, BTS, Icon, Pure Performance, TW tunes, just to name a few.

email:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Website:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Introduction only. Please email if I can help.
OBSWIZ is offline  
post #3 of 13 (permalink) Old 07-27-2009, 07:15 PM
PSN Local
 
Join Date: Jun 2009
Location: Dallas
Posts: 158
Re: Is it the oil?

I changed the oil in mine for the 1st time since buying it not long ago. I usually change all the fluids after buying a used car cause you don't know if the dealer did it or not and I just feel better about knowing there is fresh new fluids in the truck. Any ways supposedly it had Rotella 15w-40 in it and I switched it to Valvoline extreme blue 15w-40 and the truck aint felt right since. Im not seeing any smoke or codes but I have a very noticable stutter now. I feel ya man so I'll keep an eye out for ya and if you come up with anything let us know.
jgos929 is offline  
 
post #4 of 13 (permalink) Old 07-27-2009, 07:50 PM
PSN Mega Miler
 
crowz's Avatar
 
Join Date: Feb 2008
Location: Ashland, Al
Posts: 6,480
Re: Is it the oil?

5w40 or 15w40? The extreme blue Im running is 5w40 and runs great in my truck.

2002 F250 SuperDuty Lariat PSD 7.3 Crew Cab 4x4 302,000+ miles.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, Valvoline Extreme Blue 5w40 Synthetic,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, Clifford Matrix 50.5x Alarm

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, P3 Brake Controller, Swamps Injectors, PHP Tunes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
crowz is offline  
post #5 of 13 (permalink) Old 07-27-2009, 11:11 PM Thread Starter
PSN Local
 
trucknut56's Avatar
 
Join Date: Feb 2009
Location: Brussels ON CANADA
Posts: 122
Re: Is it the oil?

I switched because several people reccomended the 15w40 over the 10w30. The Swepco is a diesel rated motor oil. There claim is that my motor will run much freer and that the idle will smooth out and drop 100 to 200 rpms, they also claim 20,000 KM on an oil change, which im not going to try.
The truck does not have a stutter but just feels all around sluggish.
trucknut56 is offline  
post #6 of 13 (permalink) Old 07-27-2009, 11:14 PM
PSN Veteran
 
Stroker67's Avatar
 
Join Date: Dec 2008
Location: Worthington, Kentucky
Posts: 2,983
Re: Is it the oil?

valvoline premium blue 5w-40 synthetic, just changed mine from 15w-40 and my truck runs better

06 F250 Lariat CC SB FX4 6.0, EGR Delete by FCDP , 58v FICM by Quick Tricks, Autometer Gauges (Boost, Pyrometer, Trans. Temp), SCT X3 W/ IDT, 4" TB Straight Pipe, S&B CAI, ZOODAD, Retro-Solutions HID Kit (4300k), CCV Mod, Coolant Filter

Quote:
Originally Posted by fordfreak4life View Post
no reason to get butt hurt like someone shoved a lamp up ur butticusrumpus or somthin
Stroker67 is offline  
post #7 of 13 (permalink) Old 07-28-2009, 12:19 AM Thread Starter
PSN Local
 
trucknut56's Avatar
 
Join Date: Feb 2009
Location: Brussels ON CANADA
Posts: 122
Re: Is it the oil?

Has anybody here tried the SWEPCO 306 Diesel motor oil?
trucknut56 is offline  
post #8 of 13 (permalink) Old 07-28-2009, 12:47 AM
PSN Mega Miler
 
crowz's Avatar
 
Join Date: Feb 2008
Location: Ashland, Al
Posts: 6,480
Re: Is it the oil?

Seems that company has had some issues with their diesel oil.

SWEPCO says don't use SM oils in pre 2007 cars - Bob Is The Oil Guy

Not sure if that fits your problems or not but it might help.

2002 F250 SuperDuty Lariat PSD 7.3 Crew Cab 4x4 302,000+ miles.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, Valvoline Extreme Blue 5w40 Synthetic,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, Clifford Matrix 50.5x Alarm

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, P3 Brake Controller, Swamps Injectors, PHP Tunes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
crowz is offline  
post #9 of 13 (permalink) Old 07-28-2009, 01:19 AM Thread Starter
PSN Local
 
trucknut56's Avatar
 
Join Date: Feb 2009
Location: Brussels ON CANADA
Posts: 122
Re: Is it the oil?

Thanks. According to that report the SWEPCO 306 is the correct oil for my truck. Still does not explain why it made it run like it does. Im thinking of switching to amsoil soon along with a bypass oil filteration system.
trucknut56 is offline  
post #10 of 13 (permalink) Old 07-28-2009, 08:49 PM
PSN Veteran
 
Austinj427's Avatar
 
Join Date: Mar 2009
Location: Parker, Colorado
Posts: 1,477
Re: Is it the oil?

Hey nut,

Try out some Valvoline premium blue 15w-40.

I liked the change in my truck from Rotella to that. Real smooth idle now.
Austinj427 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome