Normal? - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 04-15-2011, 04:57 AM Thread Starter
OBS Roller
 
Join Date: Nov 2010
Location: Gorham Kansas
Posts: 250
Normal?

Is it normal when you turn the ignition switch to the run position (before starting) that you can hear something click like a circuit breaker almost. and the odometer goes blank for like 2 seconds and then comes back on?
97_f250_7.3L is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 04-15-2011, 04:58 AM
INFAMOUS
 
LOSTCAUSEPOWERSTROKE's Avatar
 
Join Date: Dec 2009
Location: Denver Colorado
Posts: 340
Re: Normal?

Glow plug relay...

Camacho
99 F-350 Single cab LB 4x4 Just an old farm truck!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
color="Red">BALLISTIC DIESEL PERFORMANCE


PROUD SUPPORTER OF THE RACE FOR THE WARRIORS!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
LOSTCAUSEPOWERSTROKE is offline  
post #3 of 11 (permalink) Old 04-15-2011, 04:59 AM
Running at last...
 
powerstroke cowboy's Avatar
 
Join Date: Jul 2009
Location: Montana
Posts: 2,782
Re: Normal?

Quote:
Originally Posted by LOSTCAUSEPOWERSTROKE View Post
Glow plug relay...

97 CCLB 4x4 ZF6 [email protected]
powerstroke cowboy is offline  
 
post #4 of 11 (permalink) Old 04-15-2011, 05:06 AM Thread Starter
OBS Roller
 
Join Date: Nov 2010
Location: Gorham Kansas
Posts: 250
Re: Normal?

It is bad im guessing? I priced GP at ford the other day. They were 11.37 a piece.
97_f250_7.3L is offline  
post #5 of 11 (permalink) Old 04-15-2011, 05:19 AM
Running at last...
 
powerstroke cowboy's Avatar
 
Join Date: Jul 2009
Location: Montana
Posts: 2,782
Re: Normal?

no the clicking sound is normal..

Too test if it is bad you need a voltage tester.. or two cold nights

97 CCLB 4x4 ZF6 [email protected]
powerstroke cowboy is offline  
post #6 of 11 (permalink) Old 04-15-2011, 02:00 PM
PSN Veteran
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 5,373
Re: Normal?

Odo behavior is normal too. If it clicks / blinks repeatedly, then worry.
madpogue is offline  
post #7 of 11 (permalink) Old 04-15-2011, 02:40 PM
OBS Addict
 
7.3psd97444's Avatar
 
Join Date: Mar 2011
Location: Blairsville PA
Posts: 1,538
Re: Normal?

yeah and if its quiet enough you can hear the gp relay working. sort of a whine niose.

-Jordan-
97 SCLB 7.3 Handshaker
Valair Clutch, only the best.
TS 6 Position Tyrant Tuning
S&B, MBRP, Isspro, Mag-Hytec, 1.00 A/R Exhaust housing, HPX
Full sound system: Kicker-Kenwood
BILLET BADGES
Dick Cepek DC-2's/Duratracs
On-Board Air
Few cosmetics
PSA # 269
7.3psd97444 is offline  
post #8 of 11 (permalink) Old 04-15-2011, 03:16 PM
Running at last...
 
powerstroke cowboy's Avatar
 
Join Date: Jul 2009
Location: Montana
Posts: 2,782
Re: Normal?

Quote:
Originally Posted by madpogue View Post
Odo behavior is normal too. If it clicks / blinks repeatedly, then worry.
Are pickup did that at one time and would not start.. So we cleaned the batterys and charged them and the problem was gone.. kind of funny

97 CCLB 4x4 ZF6 [email protected]
powerstroke cowboy is offline  
post #9 of 11 (permalink) Old 04-15-2011, 08:56 PM
PSN Veteran
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 5,373
Re: Normal?

Quote:
Originally Posted by powerstroke cowboy View Post
Are pickup did that at one time and would not start.. So we cleaned the batterys and charged them and the problem was gone.. kind of funny
Typical symptom of either a GP/GPR problem, weak batteries or, like your case, battery connection issue.
madpogue is offline  
post #10 of 11 (permalink) Old 04-18-2011, 02:01 AM Thread Starter
OBS Roller
 
Join Date: Nov 2010
Location: Gorham Kansas
Posts: 250
Re: Normal?

OK. I just wanted to be sure. It seems like i have an issue with starting. It will fire then die. Then fire then die. Then fire then almost die and then smooths out? Any ideas?
97_f250_7.3L is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome