Window problems... - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 04-04-2011, 04:53 AM Thread Starter
PowerStroke Fan
 
patrick66's Avatar
 
Join Date: Oct 2010
Location: central OK
Posts: 60
Window problems...

Up til around January or so, all four power windows worked fine in my '95 Crew Cab. Now, I've got some problems...

1) The DS front window goes down fine, but UP is another thing. If I make the mistake of rolling it down all the way, it's a bee-atch to grab the glass and help it back up with the motor and my hand. You can hear the motor go, and sometimes it'll grab the window and roll it up.

2) The DS rear window is similar...goes down fine, but will not go back up without manually assisting it, Same problem, whether with the master or the rear door switch.

3) The PS front is good, knock on wood...

4) The PS rear is finicky. It'll go up and down fine most times, but I have difficulty occasionally with the UP with the master and door switches both on that window.

I've checked the archives and can't find what I'm looking for, far as an answer goes. Any ideas?

1995 F350 SRW XLT 4x4 LB CC
patrick66 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 04-04-2011, 05:08 AM
Team Shade-Tree Mechanic
 
Mini-Stroke...'s Avatar
 
Join Date: May 2009
Location: Burlington, NC
Posts: 635
Send a message via AIM to Mini-Stroke...
Re: Window problems...

Have you pulled the door panels and looked to see if the track is messed up or if the regulator is on its way out?

96 PSD 4X4, 33's, intake, 4" straight exhaust, Autometer NV gauges, Edge
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, ZF5 tranny, LUK clutch. D60 swap in the works......

87 Diesel ranger 4X4
Mini-Stroke... is offline  
post #3 of 12 (permalink) Old 04-04-2011, 06:00 AM
PSN Local
 
Join Date: Jun 2010
Location: Idaho... potatoes aint the only thing that we grow
Posts: 270
Re: Window problems...

If you can hear the motor spinning but nothing happens, the plastic pieces inside are broken. I have taken them apart and fixed them, but should just replace the whole motor.
dave186 is offline  
 
post #4 of 12 (permalink) Old 04-04-2011, 04:00 PM
PSN Veteran
 
zilla68's Avatar
 
Join Date: Jan 2009
Location: Moore, Oklahoma
Posts: 1,557
Re: Window problems...

mine did the same thing, tracks were completely dry, greased them up with lithium type grease and they work great ever since.

Chris

Moore, Oklahoma



1996 Ford F350 4x4 Crew Cab PSD
6637 tymar
285-75-16 BFG All Terrains/Weld Wheels
3:55 gears
Automatic with billet convertor, tugger and alto discs
New Gearhead Tunes:
1 heavy tow
2 stealth mode
3 tow/econ
4 street perf
5 all out
6 high idle
1.0 housing
exhaust
zilla68 is offline  
post #5 of 12 (permalink) Old 04-04-2011, 04:21 PM
PSN Local
 
Join Date: May 2010
Location: Fremont, Michigan
Posts: 172
Re: Window problems...

Mine was the regulator check that also
rake18 is offline  
post #6 of 12 (permalink) Old 04-04-2011, 09:36 PM
PSN Veteran
 
Patrick Feeley's Avatar
 
Join Date: Mar 2008
Location: Tehachapi, CA
Posts: 2,846
Re: Window problems...

The passenger side rear on my 94 did the same thing. It turned out to be the plastic "dogs" in the motor drive that disintegrated. You can get new ones in the HELP! section at your local auto parts place (part number 74410). Some folks have also used 5/16" nuts to replace those parts. Cheers!

97 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, Ext Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD: 94 F350 CC DRW PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, 3” DP, Bilsteins, $12 AIC, Coolant Filter, Explorer O/H Console, Trans Temp, Boost, and Pyro, Pedestal Mod, Gutted EBPV

Last edited by Patrick Feeley; 04-04-2011 at 09:58 PM. Reason: Added part number
Patrick Feeley is offline  
post #7 of 12 (permalink) Old 04-04-2011, 11:07 PM
STILL LEARNING
 
Bradbilt's Avatar
 
Join Date: Oct 2008
Location: Gilbert PA
Posts: 18,317
Re: Window problems...

I got to look into my 97 crew. The passenger rear window does nothing. I hope its not a broken wire

Looking for Blue 40-20-40 seat for OBS. PM me if any known
Bradbilt is offline  
post #8 of 12 (permalink) Old 04-04-2011, 11:10 PM
Offical Puddle Displacer
 
pstroke96's Avatar
 
Join Date: May 2009
Location: Connecticut
Posts: 2,339
Send a message via AIM to pstroke96
Re: Window problems...

we had the same issue on our thunderbird, i dont know if its the same setup but on the motor there is a plastic gear inside another metal gear so if it binds up the plastic gear strips instead of damaging the motor, ive never had the window assy apart so i dont know if its the same on the trucks

Refugee
pstroke96 is offline  
post #9 of 12 (permalink) Old 04-04-2011, 11:21 PM Thread Starter
PowerStroke Fan
 
patrick66's Avatar
 
Join Date: Oct 2010
Location: central OK
Posts: 60
Re: Window problems...

Outstanding, thanks for the hints. Now, I've got something to do this weekend with a reasonable idea of a fix...or fixes.

1995 F350 SRW XLT 4x4 LB CC
patrick66 is offline  
post #10 of 12 (permalink) Old 04-05-2011, 11:20 PM
PSN Local
 
04yfzkid's Avatar
 
Join Date: Jun 2010
Location: Oceanside, Ca / Minot, ND
Posts: 498
Re: Window problems...

Quote:
Originally Posted by Patrick Feeley View Post
The passenger side rear on my 94 did the same thing. It turned out to be the plastic "dogs" in the motor drive that disintegrated. You can get new ones in the HELP! section at your local auto parts place (part number 74410). Some folks have also used 5/16" nuts to replace those parts. Cheers!
Thanks for the part number!

Quote:
Originally Posted by zilla68 View Post
mine did the same thing, tracks were completely dry, greased them up with lithium type grease and they work great ever since.
I will have to try that! My truck was texas truck so I am sure they are probably dry by now. The back ones go up really really slow.

Quote:
Originally Posted by diesel_brad View Post
I got to look into my 97 crew. The passenger rear window does nothing. I hope its not a broken wire
On my driver side rear, I had the wire break between the b-piller and the door. It was really obvious when I was detailing it one day. I was pissed because I drove it for several months like that, and cruising the beach in cali with 3 windows down was weird

04 cobra - MMR 5.0 stroker, 3.4 whipple, e-85, 30psi of boost when the belt doesn't slip
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Currently converting to 78mm turbo.
96 f-250, diamond eye catless / mufflerless, DIY 6637, white rodgers 586-902, marinco mod, Denso High torque gear reduction starter, led door and dome lights, and PHP hydra for now.
04yfzkid is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome