Eng. Temp. light came on but... - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-30-2011, 07:32 AM Thread Starter
PSN Local
 
Join Date: Jan 2010
Posts: 111
Eng. Temp. light came on but...

Ok, so what is causing the "Eng Temp" idiot light to light up all of a sudden? The temp. gauge on the left side of the dash is still pointing between the "O" and the "R" in NORMAL. Didnt smell hot. and didn't feel hot! 4 hours later, it damm sure wasn't hot, so why is the "Eng Temp" light still glowing?
And on a nother note, the damm dome lights won't go out. I had to pull the bulbs. I checked the door triggers and they seemed ok but what do I know
jacmurr is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-30-2011, 08:01 AM
Demon Dually
 
speeddemon31176's Avatar
 
Join Date: Oct 2009
Location: Carbondale,PA
Posts: 5,140
Send a message via AIM to speeddemon31176 Send a message via Yahoo to speeddemon31176
Re: Eng. Temp. light came on but...

Engine temp light staying on regardless of temp would indicate to me that either the sending unit or the wiring to it are faulty. You could also have a faulty pcm. Your dome lights staying on can only be one of three things. Either the switch is turned to the dome light on position/faulty light switch, one of the door pin triggers are faulty, or you have the ground wire to one of the door pin switches grounding out keeping the lights on. If it is a crew cab truck, look at the wiring running from the drivers kick panel to the B post as this is a common location for the wiring to corrode and cause all sorts of problems.

97 F-350 XLT CC DRW 4X4 PSD, 285/75-16 Custom bumpers, Gauges-boost/egt/trans, Swamps IDM, 3.5"dp- 4" exh., 3" Body lift, ES bushings/mounts, Built trans, billet conv, B&M pan, Hayden cooler, Adrenaline, stage 2's, IC, H2E, E-fuel
ARP's, 910's, Smith Bros. to come
speeddemon31176 is offline  
post #3 of 12 (permalink) Old 03-30-2011, 02:59 PM Thread Starter
PSN Local
 
Join Date: Jan 2010
Posts: 111
Re: Eng. Temp. light came on but...

Can you tell me where is the eng temp sensor? and B post? TIA
jacmurr is offline  
 
post #4 of 12 (permalink) Old 03-30-2011, 06:13 PM
Crazy Talk
 
powerstrokenstang's Avatar
 
Join Date: Sep 2007
Location: Staunton VA
Posts: 3,537
Send a message via AIM to powerstrokenstang
Re: Eng. Temp. light came on but...

there are two sensors, one on top the water pump, which i believe is for the guage. the other is on the pass side part way down the motor.

1996 F-250 ex-cab -D60- Motor,fire hoses-Nate,Tuning,Cam-Matt R,P-rods,dummy plugs-Wipe Out,Huffer-Engineered diesel,Carson,Gen3,Idm-Swamps,Rods,studs,fire rings-WOP,Clutch-Valair
455/400's in,S475 T-6 mounted
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'84 f-350 2wd, 6.9l, 4spd, drw, flatbed. For Sale

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
powerstrokenstang is offline  
post #5 of 12 (permalink) Old 04-01-2011, 06:07 AM
Demon Dually
 
speeddemon31176's Avatar
 
Join Date: Oct 2009
Location: Carbondale,PA
Posts: 5,140
Send a message via AIM to speeddemon31176 Send a message via Yahoo to speeddemon31176
Re: Eng. Temp. light came on but...

The idiot light sender is on the pass side of the engine as stated above. The B post is the post that is in between the front and rear doors of a crew cab, or the rear post of a regular cab, or the post that the striker for the door latch is mounted to on a super cab.

97 F-350 XLT CC DRW 4X4 PSD, 285/75-16 Custom bumpers, Gauges-boost/egt/trans, Swamps IDM, 3.5"dp- 4" exh., 3" Body lift, ES bushings/mounts, Built trans, billet conv, B&M pan, Hayden cooler, Adrenaline, stage 2's, IC, H2E, E-fuel
ARP's, 910's, Smith Bros. to come
speeddemon31176 is offline  
post #6 of 12 (permalink) Old 04-02-2011, 04:32 AM
PSN Veteran
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 5,373
Re: Eng. Temp. light came on but...

Are you sure the dome light is turned off at the headlight switch? (Sorry; gotta eliminate the obvious...)
madpogue is offline  
post #7 of 12 (permalink) Old 04-03-2011, 04:27 PM Thread Starter
PSN Local
 
Join Date: Jan 2010
Posts: 111
Re: Eng. Temp. light came on but...

Thanks guys, but I'm still having difficulty finding the engine temp. sensor. Is there some kinda sensor location diagram so I know exactly where to look?
jacmurr is offline  
post #8 of 12 (permalink) Old 04-03-2011, 06:40 PM
Crazy Talk
 
powerstrokenstang's Avatar
 
Join Date: Sep 2007
Location: Staunton VA
Posts: 3,537
Send a message via AIM to powerstrokenstang
Re: Eng. Temp. light came on but...

i think, its been awhile since mine had one, but it should be in the block between the pass side acces bracket and the timing cover, just below the head.

1996 F-250 ex-cab -D60- Motor,fire hoses-Nate,Tuning,Cam-Matt R,P-rods,dummy plugs-Wipe Out,Huffer-Engineered diesel,Carson,Gen3,Idm-Swamps,Rods,studs,fire rings-WOP,Clutch-Valair
455/400's in,S475 T-6 mounted
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'84 f-350 2wd, 6.9l, 4spd, drw, flatbed. For Sale

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
powerstrokenstang is offline  
post #9 of 12 (permalink) Old 04-03-2011, 06:46 PM
Crazy Talk
 
powerstrokenstang's Avatar
 
Join Date: Sep 2007
Location: Staunton VA
Posts: 3,537
Send a message via AIM to powerstrokenstang
Re: Eng. Temp. light came on but...

here you go where the red circle is.

1996 F-250 ex-cab -D60- Motor,fire hoses-Nate,Tuning,Cam-Matt R,P-rods,dummy plugs-Wipe Out,Huffer-Engineered diesel,Carson,Gen3,Idm-Swamps,Rods,studs,fire rings-WOP,Clutch-Valair
455/400's in,S475 T-6 mounted
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'84 f-350 2wd, 6.9l, 4spd, drw, flatbed. For Sale

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
powerstrokenstang is offline  
post #10 of 12 (permalink) Old 04-03-2011, 06:52 PM Thread Starter
PSN Local
 
Join Date: Jan 2010
Posts: 111
Re: Eng. Temp. light came on but...

Ok, like behind the idler pully?
jacmurr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome