Installed holley red fuel pump, still wont run. - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 36 (permalink) Old 03-28-2011, 05:16 AM Thread Starter
PSN Newb
 
Join Date: Mar 2011
Posts: 17
Installed holley red fuel pump, still wont run.

I have had fuel problems since i bought this truck. My question is: today i installed a holley red pump on the feed side of the fuel lines close to the tank. I have bypassed the selctor valve and i am only using front tank. The filter bowl doesnt seem to be staying full. I have not removed the mechanical full pump yet. It isnt leaking. Just wasnt pulling hard anymore it seems. Wen i turn on the electric pump the filter bowl fills with diesel wen truck isnt running. It is a very small solid stream of guel pumping into filter bowl. A stream no bigger than a pencil lead. My question is, could the mechanical pump be restricting flow and if so how do i remove it. I see 5 lines connected to the pump. One going under the filter housing, two steel lines going to the back of the heads and two line on top of the pump with ruber hose going to two stainless steel lines which seem to run back to the tank. What are all these lines and how do i bypass them? I have read about the block out plate but cant find anything about these fuel lines. Also. The little thing on the side of the filter housings with all the fuel lines coming into it. It also feed the filter bowl with fuel. What is that called and does it have a rebuild kit or diaframs inside of it that get clogged. Any suggestions help because i am lost at what to do. System is sealed everywhere. I checked everything for leaks.
Theworkunit is offline  
Sponsored Links
Advertisement
 
post #2 of 36 (permalink) Old 03-28-2011, 05:22 AM
psn high miler
 
nastyf250@yahoo.com's Avatar
 
Join Date: Jan 2009
Location: houston texas
Posts: 96
Talking Re: Installed holley red fuel pump, still wont run.

A) quit hanging with dodge guys
B) take that chit to the chop
C) replace your pickup tube like i told u yesterday
And replace all the parts you've misplaced

Thanks and have a blessed day!

97 excab lb 7.3 4x4 all stock

07 cclb lariat 4x4 6.o. adios mf

2011 cclb drw 4x4 6.7 bone stock
post #3 of 36 (permalink) Old 03-28-2011, 05:25 AM Thread Starter
PSN Newb
 
Join Date: Mar 2011
Posts: 17
Re: Installed holley red fuel pump, still wont run.

Pickup tubes in tank are not cracked. Pressure tested today.
Theworkunit is offline  
 
post #4 of 36 (permalink) Old 03-28-2011, 05:30 AM
psn high miler
 
nastyf250@yahoo.com's Avatar
 
Join Date: Jan 2009
Location: houston texas
Posts: 96
Re: Installed holley red fuel pump, still wont run.

Using as a bong does not equal pressure testing

97 excab lb 7.3 4x4 all stock

07 cclb lariat 4x4 6.o. adios mf

2011 cclb drw 4x4 6.7 bone stock
post #5 of 36 (permalink) Old 03-28-2011, 05:34 AM
crazed & deranged farmer
 
NutFarmer97's Avatar
 
Join Date: Feb 2010
Location: Forest Grove, Oregon
Posts: 1,054
Re: Installed holley red fuel pump, still wont run.

The stock fuel system on an OBS such as yours has a two stage mechanical fuel pump. It sucks fuel from the tanks, then feeds it to the fuel bowl, then back to the pump pressurized to the back of the heads. from there it feeds the injectors and at the front of the heads has 2 return lines that go to the fuel bowl where the pressure is regulated then the fuel is returned to the fuel tanks.

By putting the holly fuel pump to feed the fuel pump it wont necessarly fix your problem. As for removing all the lines, you can do this but i dont think that holley red fuel pump will be enough to support the proper fuel pressure. Look for posts on a Regulated Return Fuel System, this will help you convert the truck to E-Fuel and eliminate the mechanical pump and the fuel bowl.

1997 f350 CCLB 4x4 PSD, stage III hybrids 250cc/80%, 38r, SD-IC, NAPA 6637 air filter, Reg-Return AirDog II, TE Moded 17* HPOP, SD 3" intakes & spider, TS chip w/Matt's tunes, & built E4OD. Hydroboost brakes, 350K

1995 f350 cclb xl no frills work truck. Powerstroke 5 speed 4x4 all stock 322K
NutFarmer97 is offline  
post #6 of 36 (permalink) Old 03-28-2011, 05:36 AM Thread Starter
PSN Newb
 
Join Date: Mar 2011
Posts: 17
Re: Installed holley red fuel pump, still wont run.

Haha. Yeah i'll have to remember that next time. Nastyf250 u own a 6.0 i feel ur pain. Any real suggestion on my fuel problem?
Theworkunit is offline  
post #7 of 36 (permalink) Old 03-28-2011, 05:37 AM
PSN Veteran
 
Join Date: Apr 2008
Location: Bryan, TX
Posts: 5,346
Re: Installed holley red fuel pump, still wont run.

A Holley Red only makes like 7 psi.....
mattr66 is offline  
post #8 of 36 (permalink) Old 03-28-2011, 05:38 AM Thread Starter
PSN Newb
 
Join Date: Mar 2011
Posts: 17
Re: Installed holley red fuel pump, still wont run.

Ok thanks i'll try to look that up. Yeah it really seem like the holley isnt strong enough to push all the way to the injectors.
Theworkunit is offline  
post #9 of 36 (permalink) Old 03-28-2011, 05:38 AM
PSN Local
 
Marc's Avatar
 
Join Date: Jul 2007
Posts: 162
Re: Installed holley red fuel pump, still wont run.

If your fuel pump is dead, installing a pump downstream of it wont help. The fuel pump in your truck is a dual purpose fuel pump. It has a low pressure side that draws fuel through the tank, and a high pressure side that pushes the fuel through the filter and then to the injectors (with the excess fuel going back to the tank past he fuel pressure regulator). The best case senerio with a pump between the tank and the factory pump is helping a weak pump function. It woiuld not help a failed pump in any way or make the problem go away (assuming fuel pressure is actually your problem).

NHRDA Region 2 Race Director

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Marc is offline  
post #10 of 36 (permalink) Old 03-28-2011, 05:39 AM
crazed & deranged farmer
 
NutFarmer97's Avatar
 
Join Date: Feb 2010
Location: Forest Grove, Oregon
Posts: 1,054
Re: Installed holley red fuel pump, still wont run.

Quote:
Originally Posted by Theworkunit View Post
Ok thanks i'll try to look that up. Yeah it really seem like the holley isnt strong enough to push all the way to the injectors.
Just to give you an idea of the kind of pressure you need for larger injectors, My truck runs at 65psi to the injectors at idle.

1997 f350 CCLB 4x4 PSD, stage III hybrids 250cc/80%, 38r, SD-IC, NAPA 6637 air filter, Reg-Return AirDog II, TE Moded 17* HPOP, SD 3" intakes & spider, TS chip w/Matt's tunes, & built E4OD. Hydroboost brakes, 350K

1995 f350 cclb xl no frills work truck. Powerstroke 5 speed 4x4 all stock 322K
NutFarmer97 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome