Installed holley red fuel pump, still wont run. - Page 2 - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 36 (permalink) Old 03-28-2011, 05:41 AM Thread Starter
PSN Newb
 
Join Date: Mar 2011
Posts: 17
Re: Installed holley red fuel pump, still wont run.

Ok. If i replace the pump. I read there was something to worry about, falling into engine? Is the mechanical pump easy to replace or dangerous? And will the pump fail without weeping or leaking into oil?
Theworkunit is offline  
Sponsored Links
Advertisement
 
post #12 of 36 (permalink) Old 03-28-2011, 05:43 AM Thread Starter
PSN Newb
 
Join Date: Mar 2011
Posts: 17
Re: Installed holley red fuel pump, still wont run.

I have been scared to change pump because i dont want to ruin the engine if i drop something in it that shouldnt be.
Theworkunit is offline  
post #13 of 36 (permalink) Old 03-28-2011, 05:43 AM
PSN Local
 
Marc's Avatar
 
Join Date: Jul 2007
Posts: 162
Re: Installed holley red fuel pump, still wont run.

Quote:
Originally Posted by Theworkunit View Post
Haha. Yeah i'll have to remember that next time. Nastyf250 u own a 6.0 i feel ur pain. Any real suggestion on my fuel problem?
Im no moderator on this forum, nor do i carry any weight around here....But being an @%* to someone who seems to have the right idea on ways to help you is not the way to go........Especially when putting a fuel pump on a truck in a way that wont help it function was your answer. Just my two cents.......

And just for the record......Most 6.0 or 6.4 owners on these forums have owned or had pretty good experience with late model and OBS 7.3's......so just because he owns a 6.0 now, dont assume he doesnt know 7.3's as well.

I dont own a diesel at all.....So i guess by your statement above i dont know anything so you can disregard my post.

NHRDA Region 2 Race Director

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Marc is offline  
 
post #14 of 36 (permalink) Old 03-28-2011, 05:44 AM
crazed & deranged farmer
 
NutFarmer97's Avatar
 
Join Date: Feb 2010
Location: Forest Grove, Oregon
Posts: 1,054
Re: Installed holley red fuel pump, still wont run.

Quote:
Originally Posted by Theworkunit View Post
Ok. If i replace the pump. I read there was something to worry about, falling into engine? Is the mechanical pump easy to replace or dangerous? And will the pump fail without weeping or leaking into oil?
Yes, there is a pushrod that rides on the cam. DO NOT DROP IT INTO THE MOTOR! the pump can be hard to pull out of the block if its been in for a long time. And yes a pump can fail and not seep or leak fuel to the outside of the engine or then oil system, but if you notice your oil level come up you have problems.

1997 f350 CCLB 4x4 PSD, stage III hybrids 250cc/80%, 38r, SD-IC, NAPA 6637 air filter, Reg-Return AirDog II, TE Moded 17* HPOP, SD 3" intakes & spider, TS chip w/Matt's tunes, & built E4OD. Hydroboost brakes, 350K

1995 f350 cclb xl no frills work truck. Powerstroke 5 speed 4x4 all stock 322K
NutFarmer97 is offline  
post #15 of 36 (permalink) Old 03-28-2011, 05:46 AM Thread Starter
PSN Newb
 
Join Date: Mar 2011
Posts: 17
Re: Installed holley red fuel pump, still wont run.

Nastyf250 has been my good friend for over 10yrs. My post fell in behind yours but was not intended to u. He was just messing with me so i messed with him a lil too. Our other buddy drives a dodge. Just some inside joking. Sorry bout that.
Theworkunit is offline  
post #16 of 36 (permalink) Old 03-28-2011, 05:49 AM Thread Starter
PSN Newb
 
Join Date: Mar 2011
Posts: 17
Re: Installed holley red fuel pump, still wont run.

Nutfarmer. My oil pressure is running at normal when i have been able to get it running for a minute or two
Theworkunit is offline  
post #17 of 36 (permalink) Old 03-28-2011, 05:50 AM
PSN Local
 
Marc's Avatar
 
Join Date: Jul 2007
Posts: 162
Re: Installed holley red fuel pump, still wont run.

Quote:
Originally Posted by Theworkunit View Post
Nastyf250 has been my good friend for over 10yrs. My post fell in behind yours but was not intended to u. He was just messing with me so i messed with him a lil too. Our other buddy drives a dodge. Just some inside joking. Sorry bout that.
LMAO..Well then i appologize for getting offended......Thats not what it looked like from my end.....It looked like someone offering advice and then getting the middle finger waved at them IMO even bad advice is worth considering if your to the point that your on a forum asking questions (beyond your knowledge/experience level in other words).

anyway....back to your regularly scheduled program them!!!

NHRDA Region 2 Race Director

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Marc is offline  
post #18 of 36 (permalink) Old 03-28-2011, 05:50 AM
crazed & deranged farmer
 
NutFarmer97's Avatar
 
Join Date: Feb 2010
Location: Forest Grove, Oregon
Posts: 1,054
Re: Installed holley red fuel pump, still wont run.

Quote:
Originally Posted by Theworkunit View Post
Nutfarmer. My oil pressure is running at normal when i have been able to get it running for a minute or two
I didn't say oil pressure, I said level. As in checking the dipstick... if you engine "makes oil" then you have fuel leaking into the oil system.

1997 f350 CCLB 4x4 PSD, stage III hybrids 250cc/80%, 38r, SD-IC, NAPA 6637 air filter, Reg-Return AirDog II, TE Moded 17* HPOP, SD 3" intakes & spider, TS chip w/Matt's tunes, & built E4OD. Hydroboost brakes, 350K

1995 f350 cclb xl no frills work truck. Powerstroke 5 speed 4x4 all stock 322K
NutFarmer97 is offline  
post #19 of 36 (permalink) Old 03-28-2011, 05:51 AM
PSN Local
 
Marc's Avatar
 
Join Date: Jul 2007
Posts: 162
Re: Installed holley red fuel pump, still wont run.

have you actually tested the fuel pressure with everything hooked up in stock form??

NHRDA Region 2 Race Director

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Marc is offline  
post #20 of 36 (permalink) Old 03-28-2011, 05:53 AM Thread Starter
PSN Newb
 
Join Date: Mar 2011
Posts: 17
Re: Installed holley red fuel pump, still wont run.

Wen i remove the pump. How do i keep the push rod from falling in the motor? Magnet or something. Partially pull out pump then grab push rod with needle nose?
Theworkunit is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome