Engine died at 60mph - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 39 (permalink) Old 03-19-2011, 07:42 PM Thread Starter
Underfunded
 
moonshiner's Avatar
 
Join Date: Aug 2007
Location: Oregon
Posts: 431
Send a message via AIM to moonshiner
Engine died at 60mph

Last night driving on the highway an my trucks engine shut itself off at 60mph... Then wouldnt start up again, the batteries didnt have enough juice to turn the truck over. Got a guy to come give me a jump, before then i took the terminals off an cleaned them then hooked up the chevy and let him charge the batteries.
To prepare for trying to start up the truck, i primed my fuel filter, switched tanks and broke out the John Deere ether....
Needless to say the truck wouldnt turn over... It tried super hard but it couldnt "light off"...
Any thoughts on what the hell the problem is??

1996 F350: 4.10's Detroit Locked Front/Rear, Rampage Chip, SD/Racor E-Fuel, Adrenaline, 160cc's, Bell SS/66 Turbo, SD CAC, 315/75/16's Fierce M/Ts, 6" Lift, 6ft Traction Bars, 5" Stacks.

2007 Harley FXSTB: Bassani Prostreet Pipes, Terry Comp tuner, V&H Air Cleaner

2008 Honda Ridgeline RTX

2010 VW Jetta 2.5

SEMPER FI - USMC LT.
moonshiner is offline  
Sponsored Links
Advertisement
 
post #2 of 39 (permalink) Old 03-19-2011, 09:37 PM
PSN Local
 
Krause's Avatar
 
Join Date: Jan 2011
Location: PA
Posts: 468
Re: Engine died at 60mph

Could be the alternator. The truck needs electrical signal to run, without the alternator, the truck would have run off the batts until the bitter end when they finally didnt have any juice left. Without the IDM firing the injectors it wont start/run. I had this happen to me in the middle of the night driving across the country. Had to have it towed to the nearest town, then changed the alternator in the NAPA parking lot. A boost from a local (it took a while, 1 bat wouldnt do it we had to wait for his to charge mine a bit) and I was off to the races.
Krause

96 XLT ECLB. 6.0 intercooler. 4" aero turbine, gearhead tunes. Coolant filter & CCV mod. SD Dana 60 3.73 3.5 RSK V-codes, 35 inch toyos, 18inch M/T classic locks. 260000Km
Krause is offline  
post #3 of 39 (permalink) Old 03-20-2011, 01:44 AM Thread Starter
Underfunded
 
moonshiner's Avatar
 
Join Date: Aug 2007
Location: Oregon
Posts: 431
Send a message via AIM to moonshiner
Re: Engine died at 60mph

What are my options for an upgrade of the stock unit? If there are any??

1996 F350: 4.10's Detroit Locked Front/Rear, Rampage Chip, SD/Racor E-Fuel, Adrenaline, 160cc's, Bell SS/66 Turbo, SD CAC, 315/75/16's Fierce M/Ts, 6" Lift, 6ft Traction Bars, 5" Stacks.

2007 Harley FXSTB: Bassani Prostreet Pipes, Terry Comp tuner, V&H Air Cleaner

2008 Honda Ridgeline RTX

2010 VW Jetta 2.5

SEMPER FI - USMC LT.
moonshiner is offline  
 
post #4 of 39 (permalink) Old 03-20-2011, 05:24 AM
Demon Dually
 
speeddemon31176's Avatar
 
Join Date: Oct 2009
Location: Carbondale,PA
Posts: 5,140
Send a message via AIM to speeddemon31176 Send a message via Yahoo to speeddemon31176
Re: Engine died at 60mph

Alternator wise? There are several options. DB Electrical has a few different amperage options. Powermaster has a couple as well. Even factory options up to and including going with the dual alternator setup.

97 F-350 XLT CC DRW 4X4 PSD, 285/75-16 Custom bumpers, Gauges-boost/egt/trans, Swamps IDM, 3.5"dp- 4" exh., 3" Body lift, ES bushings/mounts, Built trans, billet conv, B&M pan, Hayden cooler, Adrenaline, stage 2's, IC, H2E, E-fuel
ARP's, 910's, Smith Bros. to come
speeddemon31176 is offline  
post #5 of 39 (permalink) Old 03-20-2011, 07:57 PM Thread Starter
Underfunded
 
moonshiner's Avatar
 
Join Date: Aug 2007
Location: Oregon
Posts: 431
Send a message via AIM to moonshiner
Re: Engine died at 60mph

Could this be a cam position sensor issue??

1996 F350: 4.10's Detroit Locked Front/Rear, Rampage Chip, SD/Racor E-Fuel, Adrenaline, 160cc's, Bell SS/66 Turbo, SD CAC, 315/75/16's Fierce M/Ts, 6" Lift, 6ft Traction Bars, 5" Stacks.

2007 Harley FXSTB: Bassani Prostreet Pipes, Terry Comp tuner, V&H Air Cleaner

2008 Honda Ridgeline RTX

2010 VW Jetta 2.5

SEMPER FI - USMC LT.
moonshiner is offline  
post #6 of 39 (permalink) Old 03-20-2011, 08:00 PM
PSN Veteran
 
bluedge8's Avatar
 
Join Date: Feb 2009
Location: Clearwater, MN
Posts: 3,629
Re: Engine died at 60mph

to clarify, you are saying the starter wouldn't spin the engine over? or the truck turned over but the engine never fired?

1997 f250 4x4 sclb, auto, 3.55's, 191k, diy intake w 6637, ccv mod, pyro, boost, trans gauges, 3" dp to 4" single exh. super chips for now. scangauge
Quote:
Originally Posted by jdc753 View Post
Besides there is absolutely no way to idiot proof something, since they are always coming out with better idiots by the day
bluedge8 is offline  
post #7 of 39 (permalink) Old 03-20-2011, 08:01 PM
PSN Veteran
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,561
Re: Engine died at 60mph

If it was barely cranking over I would say that your starter was going out cause a big draw on the batteries, then in turn caused the alternator to work hard to keep the batteries charged but couldnt keep up and failed. Leaving you to drive along on battery power till they finally died.


Thats just my guess.

02 f250
countryboyrob is offline  
post #8 of 39 (permalink) Old 03-22-2011, 01:54 AM Thread Starter
Underfunded
 
moonshiner's Avatar
 
Join Date: Aug 2007
Location: Oregon
Posts: 431
Send a message via AIM to moonshiner
Re: Engine died at 60mph

Starter works fine. Its turning the engine over, but truck isn't firing up i.e. Running on its own. Changed brushes in alternator and still wouldnt start up.

1996 F350: 4.10's Detroit Locked Front/Rear, Rampage Chip, SD/Racor E-Fuel, Adrenaline, 160cc's, Bell SS/66 Turbo, SD CAC, 315/75/16's Fierce M/Ts, 6" Lift, 6ft Traction Bars, 5" Stacks.

2007 Harley FXSTB: Bassani Prostreet Pipes, Terry Comp tuner, V&H Air Cleaner

2008 Honda Ridgeline RTX

2010 VW Jetta 2.5

SEMPER FI - USMC LT.
moonshiner is offline  
post #9 of 39 (permalink) Old 03-22-2011, 01:57 AM
PSN Veteran
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,561
Re: Engine died at 60mph

Is it turning over fast or no? Is it showing anything on the tach?

02 f250
countryboyrob is offline  
post #10 of 39 (permalink) Old 03-22-2011, 02:06 AM
PSN Veteran
 
bluedge8's Avatar
 
Join Date: Feb 2009
Location: Clearwater, MN
Posts: 3,629
Re: Engine died at 60mph

ok, so are the batteries fully charged? any fluid leaks?

1997 f250 4x4 sclb, auto, 3.55's, 191k, diy intake w 6637, ccv mod, pyro, boost, trans gauges, 3" dp to 4" single exh. super chips for now. scangauge
Quote:
Originally Posted by jdc753 View Post
Besides there is absolutely no way to idiot proof something, since they are always coming out with better idiots by the day
bluedge8 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome