battery light? - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 03-10-2011, 01:03 PM Thread Starter
PSN Local
 
deezeljunky's Avatar
 
Join Date: Dec 2010
Posts: 175
battery light?

this just started happening yesterday but when i was driving home last night, i pulled in the drive and threw it in park and the battery warning light started flickering. I looked at the volts gauge and it was right in the middle where it always is. And today while sitting at a stop light the light started flickering again, and when i parkeed the truck and it was idling it came on but this time it was not flickering it just stayed on slolid, i reved it up and it went off and then came back on after i let it idle again. im thinking this s possibly the alternater going out or my batteries are bad, im not sure. An ideas? thanks!
deezeljunky is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 03-10-2011, 01:06 PM
PSN Local
 
Twisted Addiction's Avatar
 
Join Date: Sep 2010
Location: Pa
Posts: 457
Re: battery light?

when ever the light is on its your alt

Fully built motor, Trans, 400/400, s480, gen3, decompressed, internally balanced, billet rods, mahile pistons, ported heads with valve work, o ringed heads, reg return, the works
Twisted Addiction is offline  
post #3 of 17 (permalink) Old 03-10-2011, 01:25 PM
Black Stroker
 
whytry's Avatar
 
Join Date: Dec 2009
Location: Lanesville IN
Posts: 1,187
Re: battery light?

Quote:
Originally Posted by Twisted Addiction View Post
when ever the light is on its your alt
Agreed mine did the samething.

Matts tunes
Exhaust
K&N
Nozzles
A1000 fuel system
whytry is offline  
 
post #4 of 17 (permalink) Old 03-10-2011, 02:03 PM
PSN Local
 
Join Date: May 2010
Location: Fremont, Michigan
Posts: 172
Re: battery light?

Agreed Alt, The slip rings on the rotor or more than like gone or close to it to where the brushes are not riding correctly, if you pull the regulator off you should see the problem. Replace the alt and your troubles will go away.
rake18 is offline  
post #5 of 17 (permalink) Old 03-10-2011, 02:25 PM
PSN Veteran
 
wildstang3's Avatar
 
Join Date: Apr 2008
Location: Denver Colorado
Posts: 956
Re: battery light?

Quote:
Originally Posted by rake18 View Post
Agreed Alt, The slip rings on the rotor or more than like gone or close to it to where the brushes are not riding correctly, if you pull the regulator off you should see the problem. Replace the alt and your troubles will go away.
Dont go making that assumtion, here are two threads to read, I wouldn't change it. Test it with a volt ohm meter and make sure its putting out 12.5+ volts and if it is run it! Mine crapped out and I put a new one on and it does the same thing as yours is doing (been doing this for 6 months and never have starting or runability issues) read these two threads I posted about this known alternator problem!

!! battery light flashing off and on !!! - PowerStrokeNation

Battery light on dash flickering - PowerStrokeNation
wildstang3 is offline  
post #6 of 17 (permalink) Old 03-10-2011, 02:32 PM
Simple is best
 
racefan68's Avatar
 
Join Date: Nov 2010
Location: Phoenix
Posts: 281
Re: battery light?

I had the exact same thing happen and it turned out to be my positive cable harness... the one that connects the 2 batteries and runs down to starter. I went through all the TS & that is what it ended up being. Alt. was putting out fine, put new cable ends on, all sorts of things before finally nailing down the cable harness. They are notorious for causing trouble. It is very likely the reason I went through several batteries as well.

97 HD Supercab LB 4x4. E4OD w/"mini shift kit" & Schaeffers synthetic, Tru Cool cooler, 4:10's, 33's on Weld Typhoon wheels, Gauges, Swamps stage 1's, Swamps IDM, TS 6 pos chip with Swamps tunes, Tymar intake, 3" DP, 4" exhaust (had to keep cat). Weather Guard toolbox, GPS, Billet grill.
racefan68 is offline  
post #7 of 17 (permalink) Old 03-10-2011, 11:44 PM Thread Starter
PSN Local
 
deezeljunky's Avatar
 
Join Date: Dec 2010
Posts: 175
Re: battery light?

Well dang, i had no clue this was big problem with the psd's. Im going to try messin with the connections and if that dosnt work then ill just go from there. Thanks for all the help!
deezeljunky is offline  
post #8 of 17 (permalink) Old 03-11-2011, 03:50 AM
PSN Veteran
 
wildstang3's Avatar
 
Join Date: Apr 2008
Location: Denver Colorado
Posts: 956
Re: battery light?

You know racefan68 might be on to something I was under mine the other day and noticed I had some corrosion in a couple different spots on my cables, I guess I'll try changing it and see what happens!
wildstang3 is offline  
post #9 of 17 (permalink) Old 03-11-2011, 04:08 AM
PSN Local
 
LiftedSuzuki's Avatar
 
Join Date: Feb 2011
Location: Salem, OR
Posts: 64
Re: battery light?

Make sure the connector to your voltage regulator on the alternator isn't melted or screwed up like mine was. My light would flicker until I got out, jiggled the wires and then it would go away. Ended up the alternator was messed up internally as well so after a quick replacement I was on the road again (until the new one seized up 4 days later) lol

1995 F-250 7.3L 5 Speed, 4" Lift, 35" Toyos, Straight Pipe, DIY 6637 Intake, TS Chip with PHP Tunes, Glowshift Gauges
LiftedSuzuki is offline  
post #10 of 17 (permalink) Old 03-11-2011, 06:00 AM
PSN Veteran
 
Join Date: Nov 2007
Location: Kamloops, BC. Canada
Posts: 3,302
Re: battery light?

Also check the single blade plug on the top of the alternator. When this gets warn from engine vibration it will be a back connection and the Battery light will also come on. Use a little bit of dielectric grease and a pinch with pliers to crimp the female end of the plug for a snug fit...

cheers

jrc

Tan white tan 97 ECLB, D60 PMF, RSK SD springs front, airs bags rear, 4:10, intake, FFD 205/30s, DP 4 exhaust DIY E-fuel, ZF-5 now
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
B&W turnover 5th wheel with Anderson hitch.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 VW Touareg TDi Rawtek exhaust Malone tuned.
JCart is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome