Help, Another Idiot with a powerstroke! ICP trouble. - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-22-2010, 09:23 PM Thread Starter
PSN Local
 
Join Date: Apr 2010
Posts: 116
Help, Another Idiot with a powerstroke! ICP trouble.

ok, first of all.. I am new to the site and a new PS 7.3 owner.
I am not a mechanic, i know a very little but do have alot of tools that are easy to borrow.

I have a 95 7.3 that i just purchased that has a bad clutch, it has been siting for about 4 years and i picked it up for next to nothing.

While attempting to start the truck to make sure all it needs is a clutch we were having some bad reading on the ICP regulator. While spinning over the highest the PSI would get (according to the Solus) was about 130 PSI. my buddy ran a 12 volt hot wire from the battery to the positive side of the ICP Regulator and i spun it over and it fired up, we let it run for about 4 seconds and shut it off.

When checking voltage at the ICPR I am reading 12 volts but the amperage is so low it will not light my test light. Any suggestions where to go next?
Thanks
MIke

2016 F-350 CCLB Dually 4x4
1995 F-350 Power Stroke Dually, 4-door, 5 speed, 135K miles
2004 F-150 5.4 3v (
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
) Reg Cab FX4 step side, auto, 165k miles
kelley350x is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-22-2010, 10:01 PM
PSN Veteran
 
95powersmoker's Avatar
 
Join Date: Mar 2010
Location: Monroe/Ellensburg, WA
Posts: 2,502
Re: Help, Another Idiot with a powerstroke! ICP trouble.

Have you tried unplugging the ICP sensor and seeing if it will start that way? That will cause the computer to go to a default measurement of i believe 650psi oil pressure which is needed to fire your injectors. Also i would swap out your cps and see if thats the cause of the no start.

James
2000 F350 CCLB 4x4 auto, 250/200's from PIS, No Limit tunes, Isspro gauges, 4" exhaust and intake.
95powersmoker is offline  
post #3 of 5 (permalink) Old 04-22-2010, 10:36 PM
Do you smell something?
 
Wackerjr's Avatar
 
Join Date: Jul 2007
Location: SLC
Posts: 641
Re: Help, Another Idiot with a powerstroke! ICP trouble.

it isn't a CPS IF THE TRUCK STARTED>>>>>>>>>>

odds are your wiring to the IPR is shorted, take a good look at the harness and see if it is bad....
Wackerjr is offline  
 
post #4 of 5 (permalink) Old 04-22-2010, 10:42 PM Thread Starter
PSN Local
 
Join Date: Apr 2010
Posts: 116
Re: Help, Another Idiot with a powerstroke! ICP trouble.

I have not tried unplugging it. I will try that.

If the CPS sensor was bad the tachometer would not work, correct? Thats the first thing i thought of but the tach was working.

2016 F-350 CCLB Dually 4x4
1995 F-350 Power Stroke Dually, 4-door, 5 speed, 135K miles
2004 F-150 5.4 3v (
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
) Reg Cab FX4 step side, auto, 165k miles
kelley350x is offline  
post #5 of 5 (permalink) Old 04-22-2010, 11:23 PM
PSN Local
 
powerstroke095's Avatar
 
Join Date: Mar 2009
Location: Finleyville PA and WVU
Posts: 347
Re: Help, Another Idiot with a powerstroke! ICP trouble.

Quote:
Originally Posted by kelley350x View Post
I have not tried unplugging it. I will try that.

If the CPS sensor was bad the tachometer would not work, correct? Thats the first thing i thought of but the tach was working.
thats not always the case


Quote:
Originally Posted by Wackerjr View Post
it isn't a CPS IF THE TRUCK STARTED>>>>>>>>>>

odds are your wiring to the IPR is shorted, take a good look at the harness and see if it is bad....
when my CPS was going out the truck would still start, but it ran like $hit

Josh
95 F-250 ext cab lwb 4x4
custom tuned TW chip
modified H2E
DIY electric fuel
Valair ceramic clutch
Intercooled
4'' straight pipe
Dana 60 conversion in progress


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
powerstroke095 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome