need help - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-17-2010, 11:47 AM Thread Starter
learnin the hard way
 
97strkr's Avatar
 
Join Date: Sep 2009
Location: north carolina
Posts: 61
need help

okay so about 3weeks ago my truck started acting up and i have no clue what it could be. I put a 3 in down pipe ts chip on it and a new south bend clutch about 2-3 months ago, its a 97 5 spd. okay so heres the problem when i accelerate it jumps up in rpms but doesnt move i would say there is a good 10- 15 second delay it is like the truck is in nuetral i thought it was the evbpbc the turbo would spool at the end of the gear (right as i needed to shift) so i wired that open to see if that would fix it and it didnt so any ideas on what this is? thanks

2006 F250 Lariat
EGR Delete
MRBP
Blue Spring
S&B Intake
CFM +
SCT
Autometer Factory Matched Guages
97strkr is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-17-2010, 12:28 PM
Old guy from the old days
 
Believer45's Avatar
 
Join Date: Mar 2009
Location: Cincinnati, Ohio
Posts: 263
Re: need help

Manual transmission the only thing that would "not go" then "go" with no input from the driver other than pushing on the throttle pedal is a slipping clutch. Do you smell anything getting hot when this happens?

1995 F250 'Stroke 4x2 5 spd long bed, Edge Evolution CTR, homebuilt
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, switched 10k, Putco Master Boss running boards, one off heavy duty
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, 36" tall contractor cap, 287,000 miles.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for glow plug system help.
Believer45 is offline  
post #3 of 4 (permalink) Old 04-17-2010, 01:51 PM
STILL LEARNING
 
Bradbilt's Avatar
 
Join Date: Oct 2008
Location: Gilbert PA
Posts: 18,323
Re: need help

I agree w the clutch. Did you do your break in?

Looking for Blue 40-20-40 seat for OBS. PM me if any known
Bradbilt is offline  
 
post #4 of 4 (permalink) Old 04-17-2010, 02:10 PM Thread Starter
learnin the hard way
 
97strkr's Avatar
 
Join Date: Sep 2009
Location: north carolina
Posts: 61
Re: need help

i dont smell anything and i did break it in

2006 F250 Lariat
EGR Delete
MRBP
Blue Spring
S&B Intake
CFM +
SCT
Autometer Factory Matched Guages
97strkr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome