turn signals wont work - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 04-11-2010, 01:46 AM Thread Starter
krazykustomz
 
pauljackmax610's Avatar
 
Join Date: Feb 2010
Location: philadelphia,pa
Posts: 69
turn signals wont work

hello all, i just bought a 95 f350 turbo diesel,it had a plow hook up, anyways the turn signals wont work, the hazards do,,i checked all wires flashers are new the round thing in fusebox, my question is could it be the switch itself??? the wipers work as do hi beams but if they work does it mean the switch itselfs good? please help thanks
pauljackmax610 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 04-11-2010, 04:04 AM Thread Starter
krazykustomz
 
pauljackmax610's Avatar
 
Join Date: Feb 2010
Location: philadelphia,pa
Posts: 69
Re: turn signals wont work

also checked fusebox with test light and getting no power from the turn signal flasher or the turn signal fuse!!!! please help
pauljackmax610 is offline  
post #3 of 12 (permalink) Old 04-11-2010, 06:14 AM
Demon Dually
 
speeddemon31176's Avatar
 
Join Date: Oct 2009
Location: Carbondale,PA
Posts: 5,140
Send a message via AIM to speeddemon31176 Send a message via Yahoo to speeddemon31176
Re: turn signals wont work

There is more than one fuse. Fuse "L" in the power distribution box under the hood which is the center row maxi fuse(50A) closest to the front of the truck feeds fuse #13 in the fuse block in the dash. Check for power there first. Without power at fuse #13 you have no brake lights either as power to the brake switch is supplied by fuse #13 as well. Replace both fuses at location #13 in the dash fuse panel and Fuse "L" in the power distribution block under the hood and then check for power at both terminals in the opening for the directional flasher which is the one facing you when you pull the fuse panel cover off. If you get power to that point but the signals still don't work you want to pierce and test for power on the LT BLUE wire coming off of the directional falsher location. That wire sends power to the multi function switch for the turn signals. I am willing to bet that the fuse "L" is probably your problem though.

97 F-350 XLT CC DRW 4X4 PSD, 285/75-16 Custom bumpers, Gauges-boost/egt/trans, Swamps IDM, 3.5"dp- 4" exh., 3" Body lift, ES bushings/mounts, Built trans, billet conv, B&M pan, Hayden cooler, Adrenaline, stage 2's, IC, H2E, E-fuel
ARP's, 910's, Smith Bros. to come
speeddemon31176 is offline  
 
post #4 of 12 (permalink) Old 04-11-2010, 06:29 PM Thread Starter
krazykustomz
 
pauljackmax610's Avatar
 
Join Date: Feb 2010
Location: philadelphia,pa
Posts: 69
Re: turn signals wont work

i checked all fuses in cab under hood,still nothing, i have brake lights and everything else works fine but turn signals,i did new flashers and nothing,im at a loss
pauljackmax610 is offline  
post #5 of 12 (permalink) Old 04-11-2010, 06:50 PM
Demon Dually
 
speeddemon31176's Avatar
 
Join Date: Oct 2009
Location: Carbondale,PA
Posts: 5,140
Send a message via AIM to speeddemon31176 Send a message via Yahoo to speeddemon31176
Re: turn signals wont work

Paul pm replied to. By still nothing do you mean no power or do you mean the signals just don't work? If you have power and the signals still don't work the the switch is bad.

97 F-350 XLT CC DRW 4X4 PSD, 285/75-16 Custom bumpers, Gauges-boost/egt/trans, Swamps IDM, 3.5"dp- 4" exh., 3" Body lift, ES bushings/mounts, Built trans, billet conv, B&M pan, Hayden cooler, Adrenaline, stage 2's, IC, H2E, E-fuel
ARP's, 910's, Smith Bros. to come
speeddemon31176 is offline  
post #6 of 12 (permalink) Old 04-11-2010, 07:02 PM Thread Starter
krazykustomz
 
pauljackmax610's Avatar
 
Join Date: Feb 2010
Location: philadelphia,pa
Posts: 69
Re: turn signals wont work

no power to the number 7 fuse which is the turn signal fuse which is a 15 amp. then i checked the flashers theres 2 one for the 4 ways and 1 for turn signals, i checked both with test light to see if i got power, well the 4 ways has power the turn signals dont,but all lights work, brake lights,running lights,headlights,parking lights, if the multi function switch is bad would it make it loose power to the 2 items in fusebox? but wipers and high beams and flash to pass work fine
pauljackmax610 is offline  
post #7 of 12 (permalink) Old 04-11-2010, 07:07 PM
Demon Dually
 
speeddemon31176's Avatar
 
Join Date: Oct 2009
Location: Carbondale,PA
Posts: 5,140
Send a message via AIM to speeddemon31176 Send a message via Yahoo to speeddemon31176
Re: turn signals wont work

No it wouldn't but the ignition switch which feeds the fuse which feeds the directional can which then travels to the switch would. Replied to pm again. Check the Grey/yellow wire at the ignition switch for power with the key in the run position. If no power there either the igntion switch has gone bad or is out of adjustment but i would lean towards bad.

97 F-350 XLT CC DRW 4X4 PSD, 285/75-16 Custom bumpers, Gauges-boost/egt/trans, Swamps IDM, 3.5"dp- 4" exh., 3" Body lift, ES bushings/mounts, Built trans, billet conv, B&M pan, Hayden cooler, Adrenaline, stage 2's, IC, H2E, E-fuel
ARP's, 910's, Smith Bros. to come
speeddemon31176 is offline  
post #8 of 12 (permalink) Old 04-12-2010, 06:57 AM
Dreams of owning cclb
 
97obs's Avatar
 
Join Date: Apr 2010
Location: Kellyville, Oklahoma
Posts: 695
Re: turn signals wont work

Just a problem mine has...try signaling just a little bit and see if it works. if I pull the level all the way down to where is stays like it should the signal does not work. but if I pull it part of the way down then it works fine...its a pain.
97obs is offline  
post #9 of 12 (permalink) Old 04-12-2010, 06:56 PM
Demon Dually
 
speeddemon31176's Avatar
 
Join Date: Oct 2009
Location: Carbondale,PA
Posts: 5,140
Send a message via AIM to speeddemon31176 Send a message via Yahoo to speeddemon31176
Re: turn signals wont work

We diagnosed his problem. It was a bad ignition switch. the actual switch down on the column underneath.

97 F-350 XLT CC DRW 4X4 PSD, 285/75-16 Custom bumpers, Gauges-boost/egt/trans, Swamps IDM, 3.5"dp- 4" exh., 3" Body lift, ES bushings/mounts, Built trans, billet conv, B&M pan, Hayden cooler, Adrenaline, stage 2's, IC, H2E, E-fuel
ARP's, 910's, Smith Bros. to come
speeddemon31176 is offline  
post #10 of 12 (permalink) Old 04-13-2010, 09:59 PM
PSN Veteran
 
TBarrsTruck's Avatar
 
Join Date: Feb 2010
Location: Colorado
Posts: 1,209
Re: turn signals wont work

Common failure is the switch itself. If it works kinda sorta as in part way down than it's probably the switch. MIne was bad. A lot of the time the 4 ways will still work. Agreed it could also be the ignition switch!

'97 4x4 ECLB: SD IC, TW 4 pos, afe, 3-4" w/areoturbine, 4 gauge, DIY stage 1s, GTP38R, cust E-fuel, E-brake, stage3 CM meth, 439hp still trying for 600. cust stereo, highamp alt, cust paint
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


'78 F-150 RCLB: 460 swap, 3" lift, 33's,Trussed 9" w/ chrome-moly shafts, cust stereo, locked front/rear. My first love! EFI & Turbo coming soon...
TBarrsTruck is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome