Help! Truck is running weird... pedal maybe???? - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 53 (permalink) Old 04-04-2010, 03:33 AM Thread Starter
I know nothing...
 
joedaddy's Avatar
 
Join Date: Apr 2009
Location: Gridley Ks.
Posts: 6,115
Help! Truck is running weird... pedal maybe????

Went to pick up a 3 horse slant tonight, truck ran great as per normal, knocking down 18 mpg at 75mph. Get to KC hook up to the trailer and start home, truck is pulling good up to 70mph then hits a wall, pushing harder on the pedal and nothing. I stop and play around with the TS settings which only work for shift points on mine and nothing. There is a head wind and I was going up hill and it is a tall trailer but my truck usally does this easily. So I set the cruise at 70. after a few minutes I start hitting the set button to see if it increases. 1 bump - 1mph, 2 bumps - 2more mph. So I hit it like 10 time real fast, turbo screeches to life and I'm going uphill flying around cars passing 80mph! WTF!!!! could my pedal cause this or is it the PCM??

Doesn't roll with anyone or tag along to be cool...
joedaddy is offline  
Sponsored Links
Advertisement
 
post #2 of 53 (permalink) Old 04-04-2010, 02:06 PM Thread Starter
I know nothing...
 
joedaddy's Avatar
 
Join Date: Apr 2009
Location: Gridley Ks.
Posts: 6,115
Re: Help! Truck is running weird... pedal maybe????

Anybody?

Doesn't roll with anyone or tag along to be cool...
joedaddy is offline  
post #3 of 53 (permalink) Old 04-04-2010, 02:10 PM
PSN Veteran
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,561
Re: Help! Truck is running weird... pedal maybe????

whats your fuel filter look like? and the fpr screen?

mine did that once........ acted like the same way, hit the pedal and nothing happened.

02 f250
countryboyrob is offline  
 
post #4 of 53 (permalink) Old 04-04-2010, 02:20 PM Thread Starter
I know nothing...
 
joedaddy's Avatar
 
Join Date: Apr 2009
Location: Gridley Ks.
Posts: 6,115
Re: Help! Truck is running weird... pedal maybe????

The cruise would go where the pedal wouldn't.

Doesn't roll with anyone or tag along to be cool...
joedaddy is offline  
post #5 of 53 (permalink) Old 04-04-2010, 02:23 PM
PSN Veteran
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,561
Re: Help! Truck is running weird... pedal maybe????

hmmmm thats odd

I wish I knew the answered........ has it done it since then?

02 f250
countryboyrob is offline  
post #6 of 53 (permalink) Old 04-04-2010, 02:28 PM Thread Starter
I know nothing...
 
joedaddy's Avatar
 
Join Date: Apr 2009
Location: Gridley Ks.
Posts: 6,115
Re: Help! Truck is running weird... pedal maybe????

Quote:
Originally Posted by countryboyrob View Post
hmmmm thats odd

I wish I knew the answered........ has it done it since then?
This was just last night, the truck is still hooked to the trailer. It wasn't a lack of power or anything, it was accelerating to 70mph in the space of an onramp just ranout at 70 going uphill in the wind. When I used the cruise it would go as fast I wanted.

Doesn't roll with anyone or tag along to be cool...
joedaddy is offline  
post #7 of 53 (permalink) Old 04-04-2010, 02:33 PM
<---new toy
 
DPS0925's Avatar
 
Join Date: Jan 2010
Location: Southeast Texas
Posts: 856
Re: Help! Truck is running weird... pedal maybe????

Try fuel filters. you might have trash. filters are weird, they might do it one way this time and different the next. I say fuel filter. will it rev up in park or neutral? if it won't, filters


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DPS0925 is offline  
post #8 of 53 (permalink) Old 04-04-2010, 02:42 PM
Scab
 
Smokin6-0's Avatar
 
Join Date: Nov 2009
Location: Chesapeake, VA
Posts: 1,296
Re: Help! Truck is running weird... pedal maybe????

Quote:
Originally Posted by DPS0925 View Post
Try fuel filters. you might have trash. filters are weird, they might do it one way this time and different the next. I say fuel filter. will it rev up in park or neutral? if it won't, filters
He just said that the truck accelerated up to 70 with no problem.

ADAM

2004 ECSB
1997 CCLB

Quote:
Originally Posted by PSDPlayer View Post
NASCAR ditched all the 7.3L response vehicles cause they couldn't get out to the accident scene fast enough. When lives matter, HP wins.
Smokin6-0 is offline  
post #9 of 53 (permalink) Old 04-04-2010, 02:45 PM
Scab
 
Smokin6-0's Avatar
 
Join Date: Nov 2009
Location: Chesapeake, VA
Posts: 1,296
Re: Help! Truck is running weird... pedal maybe????

Quote:
Originally Posted by 1800joedaddy View Post
This was just last night, the truck is still hooked to the trailer. It wasn't a lack of power or anything, it was accelerating to 70mph in the space of an onramp just ranout at 70 going uphill in the wind. When I used the cruise it would go as fast I wanted.
I would think that if it was related to your pedal you would be able to pin that down easily. As you were accelerating continually increase the pedal and see if it gets to the point that it makes not change.

ADAM

2004 ECSB
1997 CCLB

Quote:
Originally Posted by PSDPlayer View Post
NASCAR ditched all the 7.3L response vehicles cause they couldn't get out to the accident scene fast enough. When lives matter, HP wins.
Smokin6-0 is offline  
post #10 of 53 (permalink) Old 04-04-2010, 03:33 PM Thread Starter
I know nothing...
 
joedaddy's Avatar
 
Join Date: Apr 2009
Location: Gridley Ks.
Posts: 6,115
Re: Help! Truck is running weird... pedal maybe????

Quote:
Originally Posted by Smokin6-0 View Post
I would think that if it was related to your pedal you would be able to pin that down easily. As you were accelerating continually increase the pedal and see if it gets to the point that it makes not change.
Thats the way it happened, like I'm driving at 1/2 pedal (which was the 1st thing I noticed) at 75mph then hit a hill with about 3% grade 20mph headwind 8ft tall x 6ft wide gooseneck drops to 70 and go to 3/4 pedal still at 70 foot on the floor still 70. Pull over mess with tuning knob, next hill no diff. Turn back to factory stock setting, no change. Next hill set the cruise at 70 because it just seems weird to be shoving my foot through the floor, then use accel/set button and the truck comes to life. Like the speed control in the pedal has bunk but the speed override in the PCM is working with the cruise. I'm getting ready to haul some stuff in the trailer to or new place, will see whats up today.

Doesn't roll with anyone or tag along to be cool...
joedaddy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome