battery indicator issue - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-17-2019, 03:22 PM Thread Starter
PSN Newb
 
Join Date: Oct 2019
Posts: 6
battery indicator issue

I have a 97 F-250 Heavy Duty with a 7.3. I am getting the picture of a battery in the instrument panel sometimes. I was thinking it may be the alternator but noticed that it comes on when i let off the throttle, no matter what speed the engine is turning. Any Ideas?
woffie50 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-17-2019, 07:53 PM
PSN Veteran
 
Patrick Feeley's Avatar
 
Join Date: Mar 2008
Location: Tehachapi, CA
Posts: 2,848
Re: battery indicator issue

What's the voltage gauge doing at the same time? Cheers!

97 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, Ext Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD: 94 F350 CC DRW PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, 3 DP, Bilsteins, $12 AIC, Coolant Filter, Explorer O/H Console, Trans Temp, Boost, and Pyro, Pedestal Mod, Gutted EBPV
Patrick Feeley is offline  
post #3 of 6 (permalink) Old 10-17-2019, 08:39 PM Thread Starter
PSN Newb
 
Join Date: Oct 2019
Posts: 6
Re: battery indicator issue

Voltage gauge holds steady at about 14 V.
woffie50 is offline  
 
post #4 of 6 (permalink) Old 10-18-2019, 02:00 AM
PSN Veteran
 
Join Date: Nov 2007
Location: Kamloops, BC. Canada
Posts: 3,308
Re: battery indicator issue

Not uncommon for the square plastic wiring harness plug in top of alternator to wear the blade connector via vibration. Fix is to pull plug out and with needle nose pliers pinch the female connector slightly, re install.

Cheers,
j

Tan white tan 97 ECLB, D60 PMF, RSK SD springs front, airs bags rear, 4:10, intake, FFD 205/30s, DP 4 exhaust DIY E-fuel, ZF-5 now
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
B&W turnover 5th wheel with Anderson hitch.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 VW Touareg TDi Rawtek exhaust Malone tuned.
JCart is offline  
post #5 of 6 (permalink) Old 10-18-2019, 03:03 PM Thread Starter
PSN Newb
 
Join Date: Oct 2019
Posts: 6
Re: battery indicator issue

Thanks for the advice. I had the alt tested. It was bad and replaced it.
woffie50 is offline  
post #6 of 6 (permalink) Old 10-18-2019, 08:15 PM
College Student
 
Join Date: Jan 2018
Posts: 169
Re: battery indicator issue

My truck did the same as yours occasionally for about a year or more. The battery light would just come on randomly or when coasting. Thought it was the plug to the alternator, fiddled with it and it stopped for a while then came back. Finally it became more frequent and then just stayed on. The voltage meter would flicker every time.

Turns out that the wire that funs from behind the battery box, then under the batter and coolant container to the alternator had rubbed on the hard bend and eventually shorted it self. Soldered the wires back together and it has worked since.

95 Auto. 4.10 gears. SCLB. Baby Swamps Injectors, TS-6 chip with swamps tunes, DIY E-Fuel. AFE MaxFlow. Glowshift trans, pyro, and boost. 6.0 IC KC TP38R. Converted EBPV to exhaust brake.
Cumminsdurastroke is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome