'96 No Start "Wait light" way long! - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-24-2010, 09:39 PM Thread Starter
PSN Newb
 
Join Date: Apr 2009
Posts: 21
'96 No Start "Wait light" way long!

I looked on here for this... can't find it. The wait to start light is staying on for way to long? What causes this?

I replaced the relay... I am charging the batteries again. It is very hard to turn over.

What is the cause of the wait light staying on too long?

Thanx ahead of time!
Stumppullin is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-24-2010, 10:33 PM
The Original
 
BigStroker's Avatar
 
Join Date: Oct 2008
Location: jasper, tx
Posts: 7,509
Re: '96 No Start "Wait light" way long!

Quote:
Originally Posted by Stumppullin View Post
I looked on here for this... can't find it. The wait to start light is staying on for way to long? What causes this?

I replaced the relay... I am charging the batteries again. It is very hard to turn over.

What is the cause of the wait light staying on too long?

Thanx ahead of time!
My truck goes off quick my dads takes forever to go off my bros truck it will vary. I don't think that is your problem.

Is it hard to crank when its hot or cold or both?

[CENTER]1994 F350 4x4 5spd, 1995 F250 4x4 5spd, 1996 F250 4x2 auto, 1997 F350 4x4 auto, 1997 F250 4x2 auto
#27
BigStroker is offline  
post #3 of 7 (permalink) Old 03-24-2010, 11:42 PM Thread Starter
PSN Newb
 
Join Date: Apr 2009
Posts: 21
Re: '96 No Start "Wait light" way long!

Yea.. turning over hard no matter what the weather. Ran fine last time I plowed snow.. about a month ago. Since then it has not turned over very well. I have had it on the charger for a long time last week... still no go. I got fresh batteries, maybe I should put them in.
I thought I read something on here about the "wait to start" light stayin on for a long period of time... that this was caused by something?
Stumppullin is offline  
 
post #4 of 7 (permalink) Old 03-24-2010, 11:56 PM
your mom
 
RMPowerstroke's Avatar
 
Join Date: Mar 2010
Location: Denver,Co
Posts: 211
Re: '96 No Start "Wait light" way long!

probably should put the new batterys in. also when it starts how dose it run dose it smoke alot on start up. how olds the starter.

f350 king ranch dubed. ol ranchero thanks to wayne
04 cc/lb 9inch lift C-6 built converter custom revs manual valve body r servo. powered by 12v cummins p-pump 4k gvs custom lasered dlv pump work, 5x16 sticks, singler charger for now, airdog150, its on meth lots of custom junk. hids road armor bumper and im truck broke
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
06 f-150
RMPowerstroke is offline  
post #5 of 7 (permalink) Old 03-25-2010, 01:08 AM Thread Starter
PSN Newb
 
Join Date: Apr 2009
Posts: 21
Re: '96 No Start "Wait light" way long!

NOt sure how old the starter is. Truck has 200k on it. It does seem to smoke a bit on start up. Any pointers? I have no background info on the truck... however it does not seem the old owner was much good at keeping up the maintance... It has a very dirty K&N in it. It ran excellent the one day I plowed snow it! Unreal! But I did have to boost it one time when I shut it off.
Stumppullin is offline  
post #6 of 7 (permalink) Old 03-25-2010, 01:15 AM
Banned
 
Join Date: Dec 2008
Location: waukesha, wi
Posts: 924
Send a message via AIM to yeehaw
Re: '96 No Start "Wait light" way long!

harness for plow maybe drainin batteries down? or else maybe just some bad glow plugs?
yeehaw is offline  
post #7 of 7 (permalink) Old 03-25-2010, 01:21 AM
oil burner
 
tughill283's Avatar
 
Join Date: Jul 2009
Location: tughill,upstate ny
Posts: 1,136
Re: '96 No Start "Wait light" way long!

throw them new batteries in there and clean all connections,wts light should stay on up to 30 sec depending on how cold it is,at least thats what mine does.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

96 f250, ZF5,160cc,
300k miles

96 f350 plow truck
tughill283 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome