Alternator. - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 12-06-2018, 02:21 AM Thread Starter
College Student
 
Join Date: Jan 2018
Posts: 141
Alternator.

Noticed that my battery light would flicker on and off randomly at times for the past few weeks. The battery meter on the dash will also wave slightly. It only does this when I have been driving it for a bit and am stopped at a stop light. When I am driving, the needle on the meter stays fixed and doesn't move like normal. Nor does it flash when driving, only when coming to a stop or idling at a stop light.

I pulled my battery cables and cleaned the connectors and terminals to see if that was the problem. They were pretty clean to begin with and it didn't change anything. Does this mean that my alternator is possibly going out? The truck is 256k on it and it has never been replaced. Or is it some other electrical problem I am having? The batteries are good in it as well. It just started doing this 2 or so weeks ago.

95 Auto. 4.10 gears. SCLB. Stock besides Baby Swamps Injectors and TS-6 chip with swamps tunes. AFE MaxFlow. Glowshift trans, pyro, and boost. 6.0 IC KC TP38R. Converted EBPV to exhaust brake.
Cumminsdurastroke is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 12-06-2018, 03:12 AM
PSN Veteran
 
Bugman's Avatar
 
Join Date: Aug 2007
Location: Gypsum, Co
Posts: 5,155
Re: Alternator.

Did you check the connections on the alternator itself?

Other than that it could be heat related internally in the alternator and if it has never been replaced it could be the problem.

96 F250 XLT 4x4, 4:10 gears, 5 speed, Tymar intake and HX hose, downpipe, pyro and boost guages, coolant filter, Luc clutch
Bugman is offline  
post #3 of 7 (permalink) Old 12-07-2018, 02:37 AM
PSN Veteran
 
Patrick Feeley's Avatar
 
Join Date: Mar 2008
Location: Tehachapi, CA
Posts: 2,787
Re: Alternator.

Pull the regulator off the alternator and look at the contacts for it. Mine were toast when the voltage was fluctuating at random times. New alternator solved that problem for me. Cheers!

97 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, Ext Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD: 94 F350 CC DRW PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, 3” DP, Bilsteins, $12 AIC, Coolant Filter, Explorer O/H Console, Trans Temp, Boost, and Pyro, Pedestal Mod, Gutted EBPV
Patrick Feeley is offline  
 
post #4 of 7 (permalink) Old 12-10-2018, 04:25 AM
PSN Veteran
 
Join Date: Nov 2007
Location: Kamloops, BC. Canada
Posts: 3,222
Re: Alternator.

Also if I remember correctly.... seems less and less these days... there is a plastic female plug that clips into the top of the alternator. With vibration over time the connector inside the plastic plug will wear. Unplug and pinch the connector (once you get it out of the white plastic protector), so that it grips the blade inside the alternator snugly. Reinstall.
Cheers.
j

Tan white tan 97 ECLB, D60 RSK SD springs front, airs bags rear, E4OD 4:10, intake, DP 4” exhaust
Red 97 F250 CC 3:55, D60 Air Locker front, 175/80s, T500, TW files, Tymar, SD I/C, 6.0 fan, E-air, E-Fuel, RSK, SD springs front/rear, 145 litre rear tank (now ZF-5
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
).

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 VW Touareg TDi Rawtek exhaust Malone tuned.
JCart is offline  
post #5 of 7 (permalink) Old 12-11-2018, 07:22 PM
PSN Newb
 
hoboo128's Avatar
 
Join Date: Jun 2018
Posts: 13
Re: Alternator.

I had the same symptoms. I pulled the voltage regulator on the alternator and the one brush was worn pretty bad.
hoboo128 is offline  
post #6 of 7 (permalink) Old 12-12-2018, 01:04 AM
PSN Newb
 
Join Date: Dec 2018
Posts: 1
My alternator output voltage is low on startup after a minute or so at idle it goes to normal. 97 F350 with 317k.
yankeeCowboy88 is offline  
post #7 of 7 (permalink) Old 12-12-2018, 01:42 AM
PSN Veteran
 
Bugman's Avatar
 
Join Date: Aug 2007
Location: Gypsum, Co
Posts: 5,155
Re: Alternator.

Quote:
Originally Posted by yankeeCowboy88 View Post
My alternator output voltage is low on startup after a minute or so at idle it goes to normal. 97 F350 with 317k.
That is normal.

The glow plugs will stay on for up to 2 minutes after starting and they pull a lot of amps where the alternator can not keep up with until the glow plug shut off.

96 F250 XLT 4x4, 4:10 gears, 5 speed, Tymar intake and HX hose, downpipe, pyro and boost guages, coolant filter, Luc clutch
Bugman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome