Trans/wiring issues - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 30 (permalink) Old 10-26-2018, 01:50 AM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
Trans/wiring issues

Recently bought a 96 7.3l with 305xxx on it. Was told the transmission would not shift properly. Seller said he was told the valve body was bad. So I bought the truck because I have a spare transmission and we replaced the valve body. The truck will still only go 40 mph. We also found a dead short in the wiring. Could a speed sensor be causing this?
Rooster16 is offline  
Sponsored Links
Advertisement
 
post #2 of 30 (permalink) Old 10-26-2018, 02:10 AM
Native Texan
 
masakimm's Avatar
 
Join Date: May 2016
Location: North Central Mo
Posts: 8,885
Garage
Re: Trans/wiring issues

Quote:
Originally Posted by Rooster16 View Post
Recently bought a 96 7.3l with 305xxx on it. Was told the transmission would not shift properly. Seller said he was told the valve body was bad. So I bought the truck because I have a spare transmission and we replaced the valve body. The truck will still only go 40 mph. We also found a dead short in the wiring. Could a speed sensor be causing this?
That year truck uses the same speed sensor as the dash so not likely exactly what is it doing is it not shifting out of second. I had a problem with my 97 e4od not shifting out of second. these trans had a problem with the 2-3 shift valve sticking so they made a steel replacement. Also could be a problem with the solenoid pack.

"Y'all have a wonderful"
"My name is Bob the guy floating in the lake with no arms and no legs"
TSGT Bob W Martin USAF 1948-2014


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Upgrades:
|Bellowed UpPipes|160CC Injectors|Adrenaline HPOP|Rebuilt Turbo 360 Bearing|Custom E-Fuel|Manual to Auto Conversion
|Delete Pedestal|3" Down Pipe 4" Exhaust|Dual Tensioner and Belt|Stainless Steel HPX Crossover|Custom Banks InterCooler
|42 Gal Rear Tank 35 Gal Front Tank |DP Infinity Tuner
masakimm is offline  
post #3 of 30 (permalink) Old 10-26-2018, 07:01 PM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
Yes not shifting out of second. Replaced the solenoid pack with the valve body. Could it be the torque converter?
Rooster16 is offline  
 
post #4 of 30 (permalink) Old 10-26-2018, 07:10 PM
Native Texan
 
masakimm's Avatar
 
Join Date: May 2016
Location: North Central Mo
Posts: 8,885
Garage
Re: Trans/wiring issues

well like I said the 2-3 shift valve is a known problem. the torque converter won't prevent it from shifting.either something is wrong with the wiring to the solenoid pack which should set a code in the pcm or the valve is sticking. I fought with mine a lot till I put a steel shift valve in.

"Y'all have a wonderful"
"My name is Bob the guy floating in the lake with no arms and no legs"
TSGT Bob W Martin USAF 1948-2014


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Upgrades:
|Bellowed UpPipes|160CC Injectors|Adrenaline HPOP|Rebuilt Turbo 360 Bearing|Custom E-Fuel|Manual to Auto Conversion
|Delete Pedestal|3" Down Pipe 4" Exhaust|Dual Tensioner and Belt|Stainless Steel HPX Crossover|Custom Banks InterCooler
|42 Gal Rear Tank 35 Gal Front Tank |DP Infinity Tuner
masakimm is offline  
post #5 of 30 (permalink) Old 10-27-2018, 12:02 AM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
Solenoid pack came out of the good trans. Thought we could save time by just transferring everything over but trans might just be bad.
Rooster16 is offline  
post #6 of 30 (permalink) Old 10-27-2018, 12:03 AM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
Replaced the vss on the rear end today and the same stuff is going on so might just have to bite the bullet and replace the whole thing.
Rooster16 is offline  
post #7 of 30 (permalink) Old 10-27-2018, 12:58 AM
Native Texan
 
masakimm's Avatar
 
Join Date: May 2016
Location: North Central Mo
Posts: 8,885
Garage
Re: Trans/wiring issues

Quote:
Originally Posted by Rooster16 View Post
Solenoid pack came out of the good trans. Thought we could save time by just transferring everything over but trans might just be bad.
Quote:
Originally Posted by Rooster16 View Post
Replaced the vss on the rear end today and the same stuff is going on so might just have to bite the bullet and replace the whole thing.
My trans came out of a running driving truck did nothing to the 2-3 shift valve but it still started sticking. I would not condemn it till you looking into the shift valve if the trans was worn out it would try to shift and slip. it not shifting is exactly what mine would do. have you tried to have the codes read to see if there are any. Like I said check the wiring external to the trans going to the solenoid pack if the signal never gets to the pack then I cant shift.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Upgrades:
|Bellowed UpPipes|160CC Injectors|Adrenaline HPOP|Rebuilt Turbo 360 Bearing|Custom E-Fuel|Manual to Auto Conversion
|Delete Pedestal|3" Down Pipe 4" Exhaust|Dual Tensioner and Belt|Stainless Steel HPX Crossover|Custom Banks InterCooler
|42 Gal Rear Tank 35 Gal Front Tank |DP Infinity Tuner
masakimm is offline  
post #8 of 30 (permalink) Old 10-27-2018, 01:56 AM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
Will do tomorrow thanks for the info. Will let you know what I find out.

Thanks again.
Rooster16 is offline  
post #9 of 30 (permalink) Old 10-27-2018, 02:14 AM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
Also found a plug on the transfer case that was broken. Not sure if that would cause it. Tried plugging it in and still nothing. Will check voltage on it tomorrow along with the other plug going into the solenoid pack. What should the voltage read or how do you check for a bad plug?
Rooster16 is offline  
post #10 of 30 (permalink) Old 10-29-2018, 06:56 PM Thread Starter
PSN Newb
 
Join Date: Oct 2018
Posts: 22
Will a wiring harness from same year of truck work that is a gas engine or diesel engine only?
Rooster16 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome