Rough idle loud knocking - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-28-2018, 12:29 AM Thread Starter
PSN Newb
 
Sinister_obs's Avatar
 
Join Date: Sep 2018
Posts: 4
Rough idle loud knocking

Ok so I have a 92 F250 swapped to a 95 7.3 Powerstroke. At idle the truck runs rough. About 3-5 seconds into starting the truck the cel comes comes on and the rpms increase by 200 and sounds like it’s running on 7 cylinders and knocks. Icp cpshave both been replaced. Plugged in a snap on scanner the other day and got a couple codes: P0380 P0475 P1283 P0264 P1298 P1293 from KOEO
P0478 P0470 P1211 from memory
All high pressure lines have been replaced injectors are rebuild and modified to 160/0
A couple weeks ago the truck lost power and would take 4-5 seconds to rev to 3000. Idm,engine harness, and engine bay harness have all been replaced as well. I’m at a loss for what could be goin on. Anyone got any ideas?
Sinister_obs is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-28-2018, 04:04 AM
PSN Newb
 
Join Date: Aug 2018
Posts: 8
Re: Rough idle loud knocking

That's a whole bunch'o'codes. Since a lot of them are unrelated I would guess a PCM might be the culprit. Do you have a buddy you can swap with?


Sent from my iPhone using Tapatalk
walt_mink is offline  
post #3 of 5 (permalink) Old 09-28-2018, 05:28 AM Thread Starter
PSN Newb
 
Sinister_obs's Avatar
 
Join Date: Sep 2018
Posts: 4
@walt_mink no I don’t. I don’t have to many people around here that even own these old 7.3s
Sinister_obs is offline  
 
post #4 of 5 (permalink) Old 09-29-2018, 12:25 AM
PSN Newb
 
Join Date: Aug 2018
Posts: 8
Re: Rough idle loud knocking

Alright, well, you've got a lot of codes here:

P0380 - Glow Plug Malfunction
P0475 - Exhaust Pressure Control Valve Malfunction
P1283 - IPR Circuit Failure
P0264 - Cylinder 2 Injector Circuit Low
P1298 - IDM Failure
P1293 - High Side Open Bank No. 1

P0478 - Exhaust Pressure Control Valve High
P0470 - Exhaust Pressure Sensor Malfunction
P1211 - Injector Control Pressure Sensor Above / Below Desired

To troubleshoot this, you need to look for commonality. One thing I notice is that these are all located/related to the top of the motor. Check the wire harnesses for any chewed or burnt wires. Also, check all of the ground straps - there are at least three going to the motor. What you're seeing looks like an electrical gremlin, not a massive mechanical failure.
walt_mink is offline  
post #5 of 5 (permalink) Old 09-29-2018, 03:08 AM Thread Starter
PSN Newb
 
Sinister_obs's Avatar
 
Join Date: Sep 2018
Posts: 4
Walt_mink I couldn’t imagine what more it could be. I have driven the truck for a week now and haven’t had a problem with it other than the loud knocking and idle jumping up. All the engine harness has been checked over and repaired. The fuel bowl heater isn’t hooked up because I know those were a pretty common problem to burning fuse #22 which is also to the pcm main power
Sinister_obs is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome