E40D Transmission codes - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-26-2018, 07:31 PM Thread Starter
PSN Local
 
Christian123's Avatar
 
Join Date: Apr 2016
Posts: 88
E40D Transmission codes

Just picked my truck up from having it scanned. 1996 f350 7.3 4x4. The codes pulled were P0603 (internal control module KAM error), P0344 (Cam position sensor), and P1728 (torque converter clutch). Also found out the fluid is burnt... if any of the experts could step in and tell me where I should go from here that would be great.

Thanks again,
Christian


Sent from my iPhone using Tapatalk
Christian123 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-26-2018, 08:24 PM
PSN Veteran
 
Bugman's Avatar
 
Join Date: Aug 2007
Location: Gypsum, Co
Posts: 5,361
Re: E40D Transmission codes

The 0603 will happen whenever you disconnect the batteries.

If it is running I wouldn't worry about the 0344 cam sensor problem.

Since you are having transmission problems I myself would say that you have a bad torque converter. Hopefully Mark K will chime in where with what he thinks since he is the transmission expert.

Burnt fluid could also be part of the problem since it won't lubricate as good as fresh oil.

96 F250 XLT 4x4, 4:10 gears, 5 speed, Tymar intake and HX hose, downpipe, pyro and boost guages, coolant filter, Luc clutch
Bugman is offline  
post #3 of 4 (permalink) Old 09-26-2018, 09:32 PM Thread Starter
PSN Local
 
Christian123's Avatar
 
Join Date: Apr 2016
Posts: 88
Re: E40D Transmission codes

Quote:
Originally Posted by Bugman View Post
The 0603 will happen whenever you disconnect the batteries.

If it is running I wouldn't worry about the 0344 cam sensor problem.

Since you are having transmission problems I myself would say that you have a bad torque converter. Hopefully Mark K will chime in where with what he thinks since he is the transmission expert.

Burnt fluid could also be part of the problem since it won't lubricate as good as fresh oil.


Ya I have a a feeling it could be time to rebuild, and I disconnected and reconnected batteries again, but it came back when I started driving on the highway. Also noticed it is running at a much high rpm, which Im sure also had to do with the tc. Im usually at around 1500 going 65mph, now Im at 1500 only going 50-55mph


Sent from my iPhone using Tapatalk
Christian123 is offline  
 
post #4 of 4 (permalink) Old 09-26-2018, 11:38 PM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,029
Re: E40D Transmission codes

Most likely the torque converter is bad. You can usually tell by looking at the front face of the torque converter. When it slips it gets really hot and can turn the cover of the converter blue. If it's blue, the torque converter is toast.

Mark
Former Ford Automatic Transmission Engineer

The good thing about science is that it's true whether or not you believe in it. ― Neil deGrasse Tyson
Mark Kovalsky is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome