Need help - Glow Plug Relay - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-19-2010, 03:32 AM Thread Starter
PSN Newb
 
Join Date: Oct 2009
Posts: 13
Need help - Glow Plug Relay

Was told by mechanic who performed recall today that my glow plug relay was bad and causing the starting issues. I replaced the relay and its doing the same thing. Compared with a test light to a buddy's truck and I'm not getting a signal on the purple with red stripe wire that powers the relay to bring on the glow plugs. Checked all fuses and relays - good. Found that there is a fuse link which I believe to be at the connector under heavy black plastic. Tested the wire back behind it and still no power. HELP! Thanks in advance.
firestomper is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome