97 7.3 e4od torque converter unlocks every now and then - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-17-2018, 08:32 PM Thread Starter
PSN Local
 
Join Date: Jul 2014
Posts: 55
97 7.3 e4od torque converter unlocks every now and then

Trans was rebuilt 4 years ago probly only has 15,000 miles on it never gave me a problem but I just put a new motor in the truck and have put about 400 miles on it babying it for brake in and last night I noticed the torque converter kept unlocking at 55mph and then would come back in and then it came out of overdrive for a split second then went back in and then acted fine. I drove it 45 miles today not a single problem then all the sudden it did it again and when I left a light it was holding on to gears long and wouldn't #### and flashing overdrive button. But after I shut it off for about an hour it was fine again i feel it electrical but didnt no if someone else knew. Thanks
Mr.Stroker is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-18-2018, 02:25 PM
Former Ford Trans Engr.
 
Mark Kovalsky's Avatar
 
Join Date: Aug 2007
Location: SE Florida
Posts: 3,030
Re: 97 7.3 e4od torque converter unlocks every now and then

So do you have two problems, one that it won't stay locked, and two, it's shifting in and out of overdrive?

You need to get the codes read. The flashing overdrive light means codes have been stored to tell you where to start looking. Without the codes, all I can tell you is that something is wrong. The places that read codes free CANNOT read these codes. You need a good independent shop or a Ford dealer.

Mark
Former Ford Automatic Transmission Engineer

“The good thing about science is that it's true whether or not you believe in it.” ― Neil deGrasse Tyson
Mark Kovalsky is offline  
post #3 of 3 (permalink) Old 06-23-2018, 08:24 PM Thread Starter
PSN Local
 
Join Date: Jul 2014
Posts: 55
Yes torque converter will unlock or stay locked and will some times just have no gear. I got it scanned had a code for speed sensor. I replaced that put 150 miles on with no problems then started doing it again
Mr.Stroker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome