Loss of Power and Died. HELP!!! - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-21-2018, 05:22 PM Thread Starter
PSN Newb
 
Join Date: May 2018
Posts: 1
Loss of Power and Died. HELP!!!

So I have a 1996 F350 Powerstroke. It’s a farm truck and salt truck. It has about 220k on it now and for the past week or two it’s been throwing a fit every now and then. In the morning about 50-60 degrees out when I leave my shop it runs good for about 1/2 a mile. Then it looses power, no throttle response and lugs till it stalls. Up until yesterday I was able to restart it and take back off again. After I restart it seems to run fine. I have noticed a lope at startup sometimes but not consistent. Changed the oil and the fuel filter about a week ago. As of last night she won’t fire back over after it died the last time. Any ideas. Sorry for the long post. All help appreciated.
Farmall1942 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome