No start!!! New turbo, injector o-rings, fuel pump, ipr and icp - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 04-23-2018, 07:31 AM Thread Starter
PSN Newb
 
Join Date: Dec 2014
Posts: 5
No start!!! New turbo, injector o-rings, fuel pump, ipr and icp

Hey all...Truck is a 97 350 with a 5-speed. The turbo was shot and it was getting a little harder to start when cold, so i swapped the turbo and gp's and all of the major sensors and o rings while i was in there. I cant get the truck to run now on its own, but i can get it running on a little ether (glow plugs unhooked). If the rpms stay above 1500, i can keep it running on its on power, anything less than that and it just shuts down. Going tomorrow to get a hose and a gauge made up to check the hpop. However, i did hook air to the driverside gallery and it sounds like air is coming through all 4 injectors. (Thru the oil exhaust, not the o rings). To me this says the poppets are worn, correct? Is the ether just helping the pump build the extra pressure it needs to run? Just trying to get a good handle in what is wrong. Looking more and more like i need to order injectors and a hpop. Thanks for any insight.
Bflow55 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-23-2018, 12:40 PM
PSN Local
 
Join Date: Sep 2016
Location: minnesota
Posts: 150
Re: No start!!! New turbo, injector o-rings, fuel pump, ipr and icp

Quote:
Originally Posted by Bflow55 View Post
Hey all...Truck is a 97 350 with a 5-speed. The turbo was shot and it was getting a little harder to start when cold, so i swapped the turbo and gp's and all of the major sensors and o rings while i was in there. I cant get the truck to run now on its own, but i can get it running on a little ether (glow plugs unhooked). If the rpms stay above 1500, i can keep it running on its on power, anything less than that and it just shuts down. Going tomorrow to get a hose and a gauge made up to check the hpop. However, i did hook air to the driverside gallery and it sounds like air is coming through all 4 injectors. (Thru the oil exhaust, not the o rings). To me this says the poppets are worn, correct? Is the ether just helping the pump build the extra pressure it needs to run? Just trying to get a good handle in what is wrong. Looking more and more like i need to order injectors and a hpop. Thanks for any insight.
Whats your fuel pressure?
jrdonicht is offline  
post #3 of 8 (permalink) Old 04-24-2018, 03:52 AM Thread Starter
PSN Newb
 
Join Date: Dec 2014
Posts: 5
45 psi while starting
Bflow55 is offline  
 
post #4 of 8 (permalink) Old 04-24-2018, 12:24 PM
PSN Local
 
Join Date: Sep 2016
Location: minnesota
Posts: 150
Re: No start!!! New turbo, injector o-rings, fuel pump, ipr and icp

Quote:
Originally Posted by Bflow55 View Post
45 psi while starting
Did it at least run before you changed all the major sensors? If it did I always trace back to what I have just changed and see if its something I did or a faulty sensor. Hope you get it. I cant comment on the poppet valves. Just dont have enough knowledge there. What was wrong with the turbo? Were the blades damaged{dusted engine?} Did you do a compression check?
jrdonicht is offline  
post #5 of 8 (permalink) Old 04-24-2018, 06:07 PM Thread Starter
PSN Newb
 
Join Date: Dec 2014
Posts: 5
Just checked the hpop. Deadheaded pressure was around 3500psi. My guess is a high pressure leak somewhere in heads.

The turbo was just worn, had a bad thrust bearing and was starting to leak. Compression was still good on all cylinders.
Bflow55 is offline  
post #6 of 8 (permalink) Old 04-24-2018, 06:36 PM
Moderator
 
Sbluke55's Avatar
 
Join Date: Jun 2015
Location: Colorado
Posts: 8,022
Re: No start!!! New turbo, injector o-rings, fuel pump, ipr and icp

Ok so deadhead one head them the other. That will tell you what side has the issue.

01 f-250, Standard
Rev tech 4" lift, 37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks intercooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
Sbluke55 is offline  
post #7 of 8 (permalink) Old 04-24-2018, 08:26 PM Thread Starter
PSN Newb
 
Join Date: Dec 2014
Posts: 5
2000 psi on passanger side, 0 on driver's 😳. Guess i will be trying a new set of o-rings.! I dont see any oil pissing out of injectors
Bflow55 is offline  
post #8 of 8 (permalink) Old 04-24-2018, 11:00 PM Thread Starter
PSN Newb
 
Join Date: Dec 2014
Posts: 5
Hooked air to the drivers side head and got air coming out of the exhaust spouts on injectors. There was nothing for a few seconds, then three of the four started blowing air out.
Bflow55 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome