Runs great till it doesn't... Need help! - PowerStrokeNation : Ford Powerstroke Diesel Forum
 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 08-28-2017, 02:04 AM Thread Starter
PSN Newb
 
edwester03's Avatar
 
Join Date: Apr 2017
Posts: 46
Runs great till it doesn't... Need help!

Sorry for the long post but I'm up a creek at this point.

Hey fellow psn'ers. So I've got a 94.5 powerstroke with a zf5. Owned it for 5 months now with nothing but little issues... Until this past week. It'll start up just fine after the wts light goes out. Has a miss on 1 cyl until it warms up. (Holding out for a set of baby swamps) once its warm it runs great. Starting last week It'll start right up and idle anywhere from 5 seconds to 3 minutes then sometimes shut out like I killed the ignition. All but twice after dying it'll just crank and crank with no smoke and I don't hear any injectors firing.

Hooked up my snap on red brick and saw 9 volts on cranking. Ipr and icp look good. Fuel pressure gets up over 40 when cranking. When I bought the truck I noticed the battery cables were corroded but let it slide.

I put new cables on it firat time it happened and charged the batts overnight. Fired right up and got me to work and back 2 days. Then it came back with a vengeance. Last time it died and wouldn't start I did a buzz test and it gave me a p1667 and an idm comm failure.

Borrowed dads truck for a couple days until I could look at it this weekend. Its started and run great all weekend around town. I went to the idm and pcm and tugged on wires, tapped on modules, tried anything to get it to die and it just kept on idling away. So I cant recreate it now. From what ive read idms just fail not in and out?

All seems fine for now but I know as soon as I rely on the truck its going to let me down. Any ideas where to look? While it was running today did all the self tests and everything passed with flying colors. At this rate ill be unemployed by next week. Any direction or insight would be greatly appreciated. I just want my baby back!

Sent from my LG-H871 using Tapatalk
edwester03 is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 08-28-2017, 03:15 AM
PSN Veteran
 
'Cody''s Avatar
 
Join Date: Mar 2013
Location: Twin Falls, ID
Posts: 1,049
Re: Runs great till it doesn't... Need help!

Try a new CPS

Old Blue, 97' F350, CCLB, 7.3, Auto
Air: SD IC, 3" Plenums
Fuel: E- Fuel, 160/30 Injectors
Turbo: Irate T4, S366
Oil: T500, Melling LPOP
PCM: TW TS, IDM Mod
'Cody' is offline  
post #3 of 23 (permalink) Old 08-28-2017, 03:34 AM Thread Starter
PSN Newb
 
edwester03's Avatar
 
Join Date: Apr 2017
Posts: 46
Re: Runs great till it doesn't... Need help!

Cps is 2 months old Ford part. Do they really go out that quick? Since I bought it I've done fuel bowl and for rebuild with bb shim. Cps. Water pump. Ebpv Pedestal rebuild. Ive still got the Cps I took out when I replaced it. Truck ran fine. Just did it as preventative maintenance type thing. Ill try swapping that back in tomorrow. Would it still run fine for hours and days at a time if the Cps was bad? And not allow me to do a buzz test? That's what had me thinking idm or wiring. I'm waiting for it to fail again so I can test voltages from pcm.

Sent from my LG-H871 using Tapatalk
edwester03 is offline  
 
post #4 of 23 (permalink) Old 08-28-2017, 02:31 PM
PSN Veteran
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 5,373
Re: Runs great till it doesn't... Need help!

Have you checked for codes and done a buzz test? Can you get it warm enough to do a contribution test?
madpogue is offline  
post #5 of 23 (permalink) Old 08-28-2017, 07:36 PM Thread Starter
PSN Newb
 
edwester03's Avatar
 
Join Date: Apr 2017
Posts: 46
Re: Runs great till it doesn't... Need help!

Only code I get is an iat code because its unplugged. When it does start it runs great and passes all the buzz test and cyl contribution test and the self test where it goes thru the ebpv and all that. When it shuts off or won't start I get a p1667 cid circuit fault and if I try a buzz test it gives me an idm communication failure message. It drives great for a couple days then will randomly shut off just seconds after starting and wont start back up. If I let it sit a couple days it'll start right back up.

Sent from my LG-H871 using Tapatalk
edwester03 is offline  
post #6 of 23 (permalink) Old 08-28-2017, 10:15 PM
PSN Local
 
Join Date: Sep 2016
Location: minnesota
Posts: 150
Re: Runs great till it doesn't... Need help!

Quote:
Originally Posted by edwester03 View Post
Only code I get is an iat code because its unplugged. When it does start it runs great and passes all the buzz test and cyl contribution test and the self test where it goes thru the ebpv and all that. When it shuts off or won't start I get a p1667 cid circuit fault and if I try a buzz test it gives me an idm communication failure message. It drives great for a couple days then will randomly shut off just seconds after starting and wont start back up. If I let it sit a couple days it'll start right back up.

Sent from my LG-H871 using Tapatalk


P1667 CID circuit failure---- Possible cause---Open/grounded circuit, faulty IDM
jrdonicht is offline  
post #7 of 23 (permalink) Old 08-28-2017, 10:19 PM Thread Starter
PSN Newb
 
edwester03's Avatar
 
Join Date: Apr 2017
Posts: 46
Re: Runs great till it doesn't... Need help!

That's what I came up with too. I move all the wires into the idm and pcm. Tug on all the plugs and jostle around the idm and nothing kills the motor. Would a dying idm work great for a day or two then nothing then work great again? Would it be worth sending it out to get tested or just buy a swamps upgrade idm?

Sent from my LG-H871 using Tapatalk
edwester03 is offline  
post #8 of 23 (permalink) Old 08-28-2017, 11:21 PM
PSN Local
 
Join Date: Sep 2016
Location: minnesota
Posts: 150
Re: Runs great till it doesn't... Need help!

Quote:
Originally Posted by edwester03 View Post
That's what I came up with too. I move all the wires into the idm and pcm. Tug on all the plugs and jostle around the idm and nothing kills the motor. Would a dying idm work great for a day or two then nothing then work great again? Would it be worth sending it out to get tested or just buy a swamps upgrade idm?

Sent from my LG-H871 using Tapatalk
It would be nice if you had one to try. You could send yours in also to have checked out. I wouldn't spend the money on a swamps yet till you know whats going on. Have you tried doing a injector buzz test when it wont run? You could also open up the idm and look for any water intrusion
jrdonicht is offline  
post #9 of 23 (permalink) Old 08-28-2017, 11:24 PM Thread Starter
PSN Newb
 
edwester03's Avatar
 
Join Date: Apr 2017
Posts: 46
Re: Runs great till it doesn't... Need help!

The idm sounded dry when I shake it but ill open it up and check. When it won't start and I try a buzz test I get message saying idm communication failure.

Sent from my LG-H871 using Tapatalk
edwester03 is offline  
post #10 of 23 (permalink) Old 08-29-2017, 12:38 AM
PSN Local
 
Join Date: Sep 2016
Location: minnesota
Posts: 150
Re: Runs great till it doesn't... Need help!

Quote:
Originally Posted by edwester03 View Post
The idm sounded dry when I shake it but ill open it up and check. When it won't start and I try a buzz test I get message saying idm communication failure.

Sent from my LG-H871 using Tapatalk
Short or open circuits are hard to find specially when it is random. Know anybody that's got an idm laying around? All the 94.5 to 97 I believe will work. Ebay has got some used ones for $65 free shipping But I hate throwing parts at stuff.
jrdonicht is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome