New....issues - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-11-2008, 03:26 AM Thread Starter
PSN Local
 
Join Date: Jan 2008
Posts: 79
New....issues

Hey guys, great info here. I have a First year (94) powerstroke F350 5spd dually. It just rolled over 100k last week. The only mods I have done are DIY intake, ebpv delete and a downpipe. Just recently its been tripping the check engine light. It occurs on a cold start up (after sitting for about 4 hours).....It will go out after driving for 5 minutes. Also the light comes back on at wide open throttle, past 2200rpm and goes out after rpm drops to cruising speed. Any ideas? Ive tried retrieving the codes a snapon scanners with the EEC port under the hood. The scanner was not able to pull the code. The truck runs well for the most part, it has a exhaust leak at the EBPV housing...extremely small. All filters and fluids have been recently changed. If I let the truck sit for more then 12 hours, it takes about 6 solid cranks to get it to start. Ive replaced the glow plugs and tested the GPR to be good. My main area of interest are the PCM....not allowing any scanners to retrieve codes, CPS and the MAP sensor? Any help would be greatly appreciated!
my66coupe is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-11-2008, 03:34 AM
<----Colin Banks
 
mattymx's Avatar
 
Join Date: Jul 2007
Location: Big Bear, Ca. Elev. 7000
Posts: 3,001
Re: New....issues

Have you checked the fuse to the OBD2 port? I forget off hand what fuse that is... It looks to be an issue with your EBPV though.

><>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<><
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1996 PSD F-350 crew cab 4x4, 5 speed,AB CODE CALI TRUCK- Tuned by DI

2013 F250 4x4 CCLB Platinum Edition
mattymx is offline  
post #3 of 8 (permalink) Old 01-11-2008, 03:43 AM
PSN Veteran
 
matthewd11's Avatar
 
Join Date: Nov 2007
Location: Rhode Island
Posts: 4,678
Re: New....issues

WAG, its a HPOP issue also, particularly a drain-back issue (HPOP reseviour is draining faster than it can be filled). This could also be caused by a bad LPOP not being able to keep the res full. I dont know if the pre obdII ford diesels were like the obd1 fords, but you may be able to pull codes using flash code retrieval. Look for a trapezoid type connector with 6 pins under the hood somewhere (on my 94 mustang it was right next to the passenger shock tower). If you have a test light you can pull the codes. LUK

07 CCSB 4x4 Lariat FX4 Bronze Metallic/Sage
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
matthewd11 is offline  
 
post #4 of 8 (permalink) Old 01-11-2008, 07:05 AM Thread Starter
PSN Local
 
Join Date: Jan 2008
Posts: 79
Re: New....issues

The HPOP resevoir is full.

I tried pulling the codes by jumping the STI to the STO tonight, when i turned the key to the On position, my PCM made a pop and smoked for a good 5 seconds. The truck still runs and drives fine, same check engine issues.

I figure I need to replace the PCM regardless....Maybe its time for a reflashed unit?

Any ideas on where to get one?
my66coupe is offline  
post #5 of 8 (permalink) Old 01-11-2008, 01:22 PM
6.4's are my Hero.
 
Reubine's Avatar
 
Join Date: Nov 2007
Location: Covington, IN
Posts: 2,058
Send a message via AIM to Reubine
Re: New....issues

Quote:
Originally Posted by my66coupe View Post
The HPOP resevoir is full.

I tried pulling the codes by jumping the STI to the STO tonight, when i turned the key to the On position, my PCM made a pop and smoked for a good 5 seconds. The truck still runs and drives fine, same check engine issues.

I figure I need to replace the PCM regardless....Maybe its time for a reflashed unit?

Any ideas on where to get one?

http://shop-dp-tuner.com/customersuppliedpcmflash.aspx

'95 Ford F-350, CC,4x4,SWAMPS 300/200Hybrids,H-11 Head studs,Comp 910 Springs,Chromemoly push rods,modded TE 17*, GARRETT GT40 TURBO,built trans with 3 disc billet convertor,SWAMPS 6 position chip,3"DP to 6" single, IDM Mod,Gauges,'02 SD IC,Electric Fuel system and bunch of other stuff.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reubine is offline  
post #6 of 8 (permalink) Old 01-11-2008, 03:31 PM
PSN Newb
 
Broke's Avatar
 
Join Date: Jan 2008
Location: Columbus,Ohio
Posts: 42
Re: New....issues

I'm pretty sure all the powerstroke motors are OBDII,if I remember right the 94.5 trucks didn't have all the same diag features as the later build trucks.It should have an OBDII port on the bottom of the dash towards the pass side.

96 F-350 CC 4x4 (Truck on hold due to move
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
Shackle extentions, SD turbo
35" BFG"S, fuel system
Mild Trans work, 01 HPOP
Chip,Guages,Exhaust
Broke is offline  
post #7 of 8 (permalink) Old 01-11-2008, 11:52 PM
PSN Veteran
 
mandkole's Avatar
 
Join Date: Dec 2007
Location: Ridgefield, WA
Posts: 1,623
Re: New....issues

Yes, my 94.5 has both the earlier EEC port under the hood and the OBDII under the dash. IIRC it was the only year that had both... To use the OBD port, you'll need to be sure the PCM is reflashed to 95 tunes. The stealer bent me over and did it for (to) me....

2000 F250 CCSB-- GT4294R, 250/100s, Dahl/Fuelab, PHP, scan gauge, stock 17* pump

1994 F250 4x4 SC (sold)
1997 F250 CCSB 2wd (sold)
mandkole is offline  
post #8 of 8 (permalink) Old 01-13-2008, 04:12 AM Thread Starter
PSN Local
 
Join Date: Jan 2008
Posts: 79
Re: New....issues

my local auto parts store had a handle on a pcm with a part number f5tf-bet which had the description of the updated pcm (pre-flashed). For just under 200 i tried it. Truck ran the same, and still cant pull the codes from obd1 or 2. I called the dealership, they basically told me that the pcm I installed is the updated correct pcm for the truck...but it still may need to be reflashed. Can any one tell me or link a site with the under the hood fuse/relay holder descriptions. Including the relays to the right of the fuse box....I never had a handle on a owners manual and the chilton is far from descriptive. Thanks

Mike
my66coupe is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome