97 7.3 sputters when pressing throttle pedal - PowerStrokeNation : Ford Powerstroke Diesel Forum
 1Likes
  • 1 Post By madpogue
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-31-2017, 01:17 PM Thread Starter
PSN Newb
 
Join Date: May 2017
Posts: 3
97 7.3 sputters when pressing throttle pedal

Hello all, my name Jordan and I am new to the page.

I just bought a 97 7.3 and am having a sputtering issue as listed above. I've search through the current post and couldn't find one that fit the exact criteria of my issue.

It only sputters when I'm holding the gas pedal at a steady position. And by sputter it's almost as if it's not sending diesel properly and the truck is cutting in and out but idk. It doesn't do it during idle, acceleration, or when the truck is on cruise control. It only occurs when holding the pedal steady.

Any ideas what the issues could be? Thanks in advance.
JordanTucker is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-01-2017, 04:04 PM
PSN Newb
 
Join Date: Feb 2017
Posts: 20
Re: 97 7.3 sputters when pressing throttle pedal

Could be a lot of things, I would first check the connections at the pedal and make sure they are secure. Have you replaced the fuel filter recently? See what kind of fuel pressure you have while steadily giving it throttle. How new is the oil and is it full? Also check the VSS on the rear of the diff.
papa87 is offline  
post #3 of 5 (permalink) Old 06-01-2017, 06:10 PM Thread Starter
PSN Newb
 
Join Date: May 2017
Posts: 3
Re: 97 7.3 sputters when pressing throttle pedal

I cleaned out the fuel bowl and changed the fuel filter. I also replaced the cam positioning sensor. The oil is full and was changed a couple months ago from what I was told, I'm about to change that tomorrow to see if it helps. And, I've never dealt with the VSS before but I'll do a little research on it and check it out.
JordanTucker is offline  
 
post #4 of 5 (permalink) Old 06-02-2017, 08:58 PM
PSN Veteran
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 5,373
Re: 97 7.3 sputters when pressing throttle pedal

If it runs normally with cruise control, the pedal is a high suspect. Does it accelerate and decelerate smoothly when you use ACCEL and COAST with the cruise?
JordanTucker likes this.
madpogue is offline  
post #5 of 5 (permalink) Old 06-04-2017, 09:27 PM Thread Starter
PSN Newb
 
Join Date: May 2017
Posts: 3
Re: 97 7.3 sputters when pressing throttle pedal

Well I changed the oil and oil filter and there was no change.

And yes madpogue, it's smooth. is there some kind of sensor in the pedal assembly that I can change? Or do I have to replace the whole thing?
JordanTucker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome